Need to restore only the data I backed up


New Member
May 27, 2023

I run a 3 node cluster running PVE Manager/7.4.13/46c37d9c. Each node has a 500GB Samsung HD connected via USB C comprising a 3 device ZFS pool which has been replicating successfully once I got it working properly. It's been wonderful to see it working in fact.

I made some big mistakes requiring me to rebuild my entire cluster. I erased everything including ZFS devices and started from scratch knowing a I had good backups of all VM's and CT's out on my NFS. The good news is that process was actually really great and quite easy.

Until now where I find myself in a place of tremendous frustration. My VM's and CT's - 14 of them - have all kinds of drive sizes. 64GB, 32GB, etc. Almost none of them use anything close to those totals. Most are 8GB with like 500MB on each.

If I have to restore the entire size of every single image it ruins my entire setup forcing me to buy all new hard drives. Please tell me there's something easy I"m missing.

I have tried fstrim on my Linux VM's. It doesn't help. I tried de frag on my Windows 10 Pro VM. No change. I ran zpool trim on my ZFS. It says my device doesn't support trim.

It's a tremendous amount of work if I have to rebuild all of these from scratch and even then I now have no working backup solution because I can't be forced to restore 10x the space I was occupying.

I have Discard checked on all of these storage devices where the checkbox is present. I've rebooted them multiple times using nfs and zfs as the storage. It does not discard. I don't understand the point of that checkbox.

Please tell me there's something huge and obvious I'm missing here.
Please forgive the frustration. It's been a long process.

In the time it took me to write that post, something took place that fixed it. My restored Debian build now occupies only 6GB on my ZFS as it should. The problem is I don't know which step did it!

This is what I *think* finally worked. I think because I restored the VM onto my NFS instead of ZFS and then ran fstrim on the node before moving storage back to zfs, I think that successfully trimmed. It didn't show that successful result at first which still has me quite confused. Something was still needing to cycle. I'll keep restoring to see if I can repeat that.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!