Need help with Create a CT tempalte

Gad

New Member
Feb 28, 2019
27
0
1
37
ok so i am new to proxmox but its been really kind to me, I really enjoy it so thumbs up to the team!

i have moved my entire Home Automation setup to proxmox CT of Ubuntu, while building i took advantage of the snapshots, really good for noobs, install if something went wrong just go back to the state before

but now when the system is ready i want to create a way to backup, but I am not really sure what to do so please help me understand

1. trying to create convert to a template
so i will be able to take this to another machine right?

but i am getting
error: "unable to create a template, because CT contains snapshots (500)"

when trying to delete snapshots i am getting also allot of errors ?
error: "Task failed lvremove snapshot 'pve/snap_vm-104-disk-0_BeforeAPLTV' error: Failed to find logical volume "pve/snap_vm-104-disk-0_BeforeAPLTV"
"

2. so i tried to migrate to another node i have setup
also error : 2019-04-05 10:20:49 can't migrate local volume 'local-lvm:vm-104-disk-0': owned by other guest (owner = 104)

i guess all can be solved but i am shooting all over the place ... what is the correct way to take what i created and put it on one file? so i can back it up :) or something like that

as you can see i am not a big system guy... but i believe all will be ok Proxmox is very fun :)
 
You can try clonning the ct first and then use thr clone to convert to template.
I thing you have option of clone or copy if you right-click the vm name.
 
yep tried that also the problem is it duplicated with snapshots and i have the same issue

so can anyone tell me how to delete all snapshots?
i am getting CT locked for each one, when i unlock i am getting also an error i cannot delete
 
so can anyone tell me how to delete all snapshots?

Try to delete one of the snapshots from the command line. Maybe it will give us better information.

Firstly pick a CT with some snapshots.

Code:
pct listsnapshot CTID
pct delsnapshot CTID snapname

If that doesn't work, you can try adding `--force` to the last command and see if that works.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!