My VM wont change CPU

teekieweb

New Member
Jun 27, 2023
5
1
3
Hello. I am trying to change the CPU Type of one of my VM's because of the requirement of one of the software i intent to run on the machine doesn't support KVM64, it tells me "Please use a different CPU type (such as 'host')".

I've tried to select host as CPU type under the hardware configuration on the web panel of proxmox, and restarted the VM, but when i do lscpu (yes it's ubuntu 22 btw) it says Common KVM Processor. I also tried to select Skylake-Client as CPU, still says common KVM processor.

I will attach screenshot of the panel, well as the command line interface of the server when i do lscpu.

Is there anything i am doing wrong here or?
 

Attachments

  • proxmox_cpu_issue.PNG
    proxmox_cpu_issue.PNG
    44.6 KB · Views: 11
  • proxmox_ubuntussh_issue_cpu.PNG
    proxmox_ubuntussh_issue_cpu.PNG
    38.8 KB · Views: 11
depends on how your VM is configured, based on your statements - it was not enough.


Blockbridge : Ultra low latency all-NVME shared storage for Proxmox - https://www.blockbridge.com/proxmox
Ok thanks i understand now what you meant because the simple OS reboot command still left the orange text on VE which i suppose mean "unchanged", but i did a stop from VE and started it, and now it shows the host CPU. Thank you :D
 
  • Like
Reactions: bbgeek17

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!