Multiple Linux boot managers after botched installs.


New Member
Oct 30, 2023
I am using a HP G9 PL380.

Hi guys , new to proxmox. I decided to use some different drives for the OS, and went through the install process a couple times... I now have 6 different boot managers. I reformated all of the drives using gparted but it seems that the boot managers persisted? Initially I ran all discs separate as RAID 0, 15 logical drives.
After installing I did zfs RAID 1 on the first two drives. I had some issues with prox so I wanted to do a reinstall on some other non-enterprise ssd's , pretty much doing the same thing using zfs raid 1 on the 2 samsung ssds. After this install I noticed there were 4 linux boot managers, which made me want to completely wipe the drives and just start fresh, so I used gparted to reformat all the discs, ran in HBA mode, and reinstalled prox.
Now I have 6 linux boot managers lol I think bottom line I just need to do an actual wipe, and a fresh install. Any recommendations ?

also seem to be getting these errors when attempting to boot. checking all 6 to see if they all give this message.



I was able to clear all partitions,

And cleared the extra boot entries from UEFI. I attempted a Clean install in HBA mode, using ZFS(RAID1) with 2 ssd's. Install was successful, but after rebooting I was left with the same error as above when trying to actually boot.


After trying many different ways, I am still unable to successfully boot into prox. The installs are successful, but ever since the initial install I have not been able to get it to work.

I have attempted:
HBA Mode, install/boot into prox in legacy bios mode;
RAID0 individual disks, then choosing ZFS(RAID1) on the 2 ssd's I want to install prox on (This was the original way that was working).
I have tried variations of these methods, including reformatting using gparted, wipefs, etc. I am able to clear the partitions, and installing is always successful, but now no matter what I do I get the red error screen. Would love help if anyone can. This is the error given in ILO. There have been no hardware changes, which does not make sense as to why I am getting the error message now.
Last edited:


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!