mucked it all up.

Sep 27, 2019
Hi All, had it working wonderfully and then I had to go and reck it all.

when I try to migrate a VM from one host to another I get this message

2019-09-27 19:07:52 # /usr/bin/ssh -e none -o 'BatchMode=yes' -o 'HostKeyAlias=prox3' root@ /bin/true
2019-09-27 19:07:52 Host key verification failed.
2019-09-27 19:07:52 ERROR: migration aborted (duration 00:00:00): Can't connect to destination address using public key
TASK ERROR: migration aborted

I have (unfortunatly) googled and tried to fix it myself but have made it worse but have managed to get it back to this error.

Is there a way to avoid this error so I can migrate the VM's from PROX1 to PROX3 to allow me to re-install the whole system or 4 hosts.


please test if you can ssh from PROX1 to PROX3. ssh prox3 should function without any user interaction.
using the shell and logged directly into prox1

ssh: connect to host prox4 port 22: Connection refused
ssh: connect to host prox3 port 22: Connection refused

Last edited:

check if you:

* have firewall blocking port 22 on these nodes
* have modified sshd configuration on these nodes

also please check if the connection works the other way around.

it needs to work both ways without any interaction
You can also try to run pvecm updatecerts.
Hi Guys,

thanks for the recommendations.
In the end I copied all the VM's over and started again.

All working now

PS - I had tried pvecm updatecerts


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!