[SOLVED] mount.nfs error after joining cluster (new node can not access existing node nfs)

Dalamar

New Member
Oct 23, 2019
7
3
3
50
Hi
I had a single standalone pve installation doing backups on NFS. No problem on backup or restore.
I had converted this standalone node into a cluster and successfully added a second proxmox node. I am able to run VMs and Containers and migrate between them, so everything in terms of cluster seems to be working fine. I am not using ZFS or any shared storage for VMS or containers, just NFS for backup

Now i am trying to restore ion the pmx2 node a NFS backup done from pmx1 node, but when i try to restore, i see no option to pickup the restore node

When i check pmx1 i see NFS storage as nfs_shared_name(pmx-1)
When i check pmx2 i see NFS storage as nfs_shared_name(pmx-2) with question mark, and if i access it, i get an error in the WEBUI

"mount error: mount.nfs: Protocol not supported"

Both nodes are running pve6, both are updated to the last versions (community), both servers have access to nfs server with exactly the same permissions configuration.
i am able to mount via shell directly the nfs share into the pmx-2 node and access its contents.

any ideas?
I suppose i could always do a restore using cli, but i 'd prefer to find out why it is not working at WEbUI level
 
hmm - any messages in dmesg on the second node (the one where the mount of the NFS fails)?
any messages in the journal regarding why the mount failed?

maybe there's a mismatch between the installed kernel and the running kernel - have you done a reboot recently?

I hope this helps!
 
@Stoiko Ivanov Thanks, the server was rebooted several times before and after; it was clearly no mismatch between kernel and modules as i was able to mount directly the nfs share via command line.

Anyway, removing the nfs share from WEB UI and adding it again worked, so issue solved.
 
  • Like
Reactions: Stoiko Ivanov
Glad you found a way to resolve the issue - please mark the thread as 'SOLVED' - it helps others with similar problems
Thanks!
 
Sorry if the question sounds stupid, but how do i mark the question as solved? Is it a tag? i do not see any option for this
 
Sorry if the question sounds stupid,
Not at all! - It is (sadly) somewhat hidden -> click on 'More Options' (the 3 dots ...) above the first post -> Edit Thread and select the 'SOLVED' prefix

for the next time :)
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!