Missing dependencies

Daxcor

Member
Oct 31, 2021
19
0
6
56
I am trying to install the backup client on Ubuntu 22.04.3 Server. I use the following:

wget https://enterprise.proxmox.com/debian/proxmox-release-bookworm.gpg -O /etc/apt/trusted.gpg.d/proxmox-release-bookworm.gpg
cat << EOF >> /etc/apt/sources.list
deb http://download.proxmox.com/debian/pbs-client bookworm main
EOF
apt-get update
apt-get install proxmox-backup-client -y

When I do this, I get the following error:

Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
proxmox-backup-client : Depends: libzstd1 (>= 1.5.2) but 1.4.8+dfsg-3build1 is to be installed
E: Unable to correct problems, you have held broken packages.


Then I go to try to install libzstd1 I get:

Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
libzstd1 is already the newest version (1.4.8+dfsg-3build1).
libzstd1 set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

If you can help it would be greatly appreciated.

Thanks
Brad
 
Hi,
what debian version are you on? There might be a mismatch between your debian version and the version of pbs you are trying to install.


Edit: Somehow I missed the version -.-
 
Last edited:
He wrote he is using Ubuntu which isn't officially supported. PBS only supports Debian. But if I remeber correctly there were some people getting the PBS client to work on Ubuntu by manually removing and installing packages to fix dependencies.
 
Kinda seems limiting to only have your backup solution work with one flavor of linux no? I did find some posts, I wil see if I can make it work. Might have to install debian. oh well.
 
Kinda seems limiting to only have your backup solution work with one flavor of linux no? I did find some posts, I wil see if I can make it work. Might have to install debian. oh well.
Well, I guess that's what "enterprise backup solution" means. If enterprise is using only one specific OS and nothing else.

Anyways, manually installing libzstd1_1.5.5+dfsg2-2_amd64.deb helped.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!