[SOLVED] Mac issues connecting to NFS/ZFS on Proxmox

SomeUser

New Member
Aug 1, 2020
11
2
3
50
Current version of proxmox, fully updated. Have a zpool with sharenfs enabled. Unable to nfs mount from macOS. Any ideas?

proxmox server IP is 10.100.200.200
zpool is jbod/tank
Mac IP is 10.100.200.100
Mac User is Justme
linux VM on Mac is 10.100.200.101

Code:
# zfs set sharenfs=rw@10.100.200.0/24 jbod/tank
# zfs get sharenfs jbod/tank
NAME                 PROPERTY  VALUE              SOURCE
jbod/tank  sharenfs  rw=@10.100.200.0/24  local
# cat /etc/exports
/jbod/tank  10.100.200.0/24(rw)
I can successfully run a linux VM on my Mac and run "mount -t nfs 10.100.200.200:/jbod/tank /mnt/nfs" and it mounts successfully.

However, on my Mac, if I used Connect to Server: nfs://10.100.200.200/jbod/tank, I get an error message:
Code:
There was a problem connection to the server "10.100.200.200".

Check the server name or IP address, and then try again.  If you continue to have problems, contact your system administrator.
If I run rpcinfo, showmount, and mount on the Mac:
Code:
macOS $ rpcinfo -p 10.100.200.200
   program vers proto   port
    100000    4   tcp    111  rpcbind
    100000    3   tcp    111  rpcbind
    100000    2   tcp    111  rpcbind
    100000    4   udp    111  rpcbind
    100000    3   udp    111  rpcbind
    100000    2   udp    111  rpcbind
    100005    1   udp  47653  mountd
    100005    1   tcp  48065  mountd
    100005    2   udp  60115  mountd
    100005    2   tcp  42837  mountd
    100005    3   udp  52784  mountd
    100005    3   tcp  53583  mountd
    100003    3   tcp   2049  nfs
    100003    4   tcp   2049  nfs
    100227    3   tcp   2049  nfs_acl
    100003    3   udp   2049  nfs
    100227    3   udp   2049  nfs_acl
    100021    1   udp  48581  nlockmgr
    100021    3   udp  48581  nlockmgr
    100021    4   udp  48581  nlockmgr
    100021    1   tcp  32943  nlockmgr
    100021    3   tcp  32943  nlockmgr
    100021    4   tcp  32943  nlockmgr
macOS $ showmount -e 10.100.200.200
Exports list on 10.100.200.200:
/jbod/tank           10.100.200.0/24
macOS $ sudo mkdir /Volumes/nfs
macOS $ sudo chown justme /Volumes/nfs
macOS $ mount -v -t nfs 10.100.200.200:/jbod/tank /Volumes/nfs
mount_nfs: can't mount /jbod/tank from 10.100.200.200 onto /Volumes/nfs: RPC prog. not avail
mount: /Volumes/nfs failed with 74
This mac had no issues doing NFS mounts to solaris11 running on the same physical machine as proxmox previously without issues. I would like to get NFS working again...

Thanks for your help.
 
Last edited:

wolfgang

Proxmox Staff Member
Staff member
Oct 1, 2014
6,206
424
103
Hi,

this problem has nothing to do with Proxmox VE we support only the NFS client.
Maybe the free NASor OMV forum can tell which are the correct setting for a MACOS client.
 

SomeUser

New Member
Aug 1, 2020
11
2
3
50
Found the problem - nfs server was running in secure mode, so the client needed to use the resvport option.

Code:
mount -t nfs -o soft,nfsvers=4,proto=tcp,resvport proxmox:/jbod/tank /Volumes/nfs
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!