LXC Container | mp* NFS | Always Backup

timonych

Member
Aug 8, 2017
36
3
8
29
Hi Everyone

I have a problem with Backup.
According to the Screen - there is no backup function for mp1 which is underlying on NFS Storage
upload_2019-3-29_12-12-59.png

But after restoring this mp1 is also restored as I have mentione in config backup=1, but there is no such tuning.

I have checked configuration of backup
Code:
arch: amd64
cores: 6
hostname: 1CDBUT
memory: 16384
mp0: LVM-DB:vm-146-disk-1,mp=/var/database,backup=1,size=30G
mp1: NFS-Celsium:999/dbreplica.raw,mp=/var/dbreplica,size=50G
net0: name=eth0,bridge=vmbr0,hwaddr=08:60:6E:54:98:6C,ip=dhcp,type=veth
onboot: 1
ostype: centos
rootfs: LVM-DB:vm-146-disk-0,size=2G
startup: order=10,up=5
swap: 4096

Why VZDUMP ignores that this MP1 shouldn't be backuped? Or this is NFS Storage Feautre?

Code:
proxmox-ve: 5.3-1 (running kernel: 4.15.18-11-pve)
pve-manager: 5.3-11 (running version: 5.3-11/d4907f84)
pve-kernel-4.15: 5.3-2
pve-kernel-4.15.18-11-pve: 4.15.18-34
corosync: 2.4.4-pve1
criu: 2.11.1-1~bpo90
glusterfs-client: 3.8.8-1
ksm-control-daemon: not correctly installed
libjs-extjs: 6.0.1-2
libpve-access-control: 5.1-3
libpve-apiclient-perl: 2.0-5
libpve-common-perl: 5.0-47
libpve-guest-common-perl: 2.0-20
libpve-http-server-perl: 2.0-12
libpve-storage-perl: 5.0-39
libqb0: 1.0.3-1~bpo9
lvm2: 2.02.168-pve6
lxc-pve: 3.1.0-3
lxcfs: 3.0.3-pve1
novnc-pve: 1.0.0-3
proxmox-widget-toolkit: 1.0-23
pve-cluster: 5.0-33
pve-container: 2.0-35
pve-docs: 5.3-3
pve-edk2-firmware: 1.20181023-1
pve-firewall: 3.0-18
pve-firmware: 2.0-6
pve-ha-manager: 2.0-8
pve-i18n: 1.0-9
pve-libspice-server1: 0.14.1-2
pve-qemu-kvm: 2.12.1-2
pve-xtermjs: 3.10.1-2
qemu-server: 5.0-47
smartmontools: 6.5+svn4324-1
spiceterm: 3.0-5
vncterm: 1.5-3
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
3,789
345
83
31
Vienna
backup=1 is the default, so If you want to exclude something, you need to set backup=0 ...
that is actually not true, the default for container is not to back it up, but the config gets backed up (just not the data)

so when you restore, you get the same mountpoint, but it is empty
 

timonych

Member
Aug 8, 2017
36
3
8
29
backup=1 is the default, so If you want to exclude something, you need to set backup=0 ...
Via Web GUI there is no point that I need backup for this MP1, so there is no backup=1 or backup=0 in config.
Should I place backup=0 in config by myself?
 

timonych

Member
Aug 8, 2017
36
3
8
29
that is actually not true, the default for container is not to back it up, but the config gets backed up (just not the data)

so when you restore, you get the same mountpoint, but it is empty
IF I will use LVM with such MP /dev/vg-<vgname>/dbreplica MP1 wouldn't be restored but this line will be placed in Notes.
But I can't use such mp1 with NFS storage. Is there any workaround?
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!