Linux bridge will not activate

cjkeist

New Member
Feb 11, 2020
14
0
1
51
New user to Proxmox and testing out Proxmox install with a two-node cluster. Running 6.1-3. Everything was working great and then something changed where my first node Linux bridge vmbr1 de-activated. Now any VM assigned to that Linux bridge will not see the network. What happened was I tried to delete a VM that was configured on HA. It gave me an error that I couldn't delete the VM. So I went to HA and removed that VM from the list. I then was able to delete the VM. I think I the VM was originally created on node 1, and then migrated to node2 when I then deleted the VM. When I tried creating a new VM on node1 is when I found that the vmbr1 network was no longer active.
I tried to remove and re-create, reboot the server and still that vmbr1 will not activate. Looking for any help on why I cannot get this to activate. vmbr1 is using eno4. The vmbr1 on node2 is working fine.


/etc/network# ip link show (on node1)


1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000


link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00


2: eno3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master vmbr0 state UP mode DEFAULT group default qlen 1000


link/ether 00:10:e0:40:ba:02 brd ff:ff:ff:ff:ff:ff


3: eno4: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DEFAULT group default qlen 1000


link/ether 00:10:e0:40:ba:03 brd ff:ff:ff:ff:ff:ff


4: eno1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000


link/ether 00:10:e0:40:ba:04 brd ff:ff:ff:ff:ff:ff


5: eno2: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000


link/ether 00:10:e0:40:ba:05 brd ff:ff:ff:ff:ff:ff


6: vmbr0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DEFAULT group default qlen 1000


link/ether 00:10:e0:40:ba:02 brd ff:ff:ff:ff:ff:ff


Interfaces file:
auto lo

iface lo inet loopback

iface eno3 inet manual

auto eno4
iface eno4 inet manual

iface eno1 inet manual

iface eno2 inet manual

auto vmbr0
iface vmbr0 inet static
address 10.206.20.38
netmask 24
gateway 10.206.20.1
bridge-ports eno3
bridge-stp off
bridge-fd 0
bridge-vlan-aware yes
bridge-vids 2-4094

auto vmbr1
iface vmbr1 inet manual
bridge-ports eno4
bridge-stp off
bridge-fd 0
bridge-vlan-aware yes
bridge-vids 2-4094
 

cjkeist

New Member
Feb 11, 2020
14
0
1
51
Found it. When I tried to bring up the bridge via command line I got this:
ifup vmbr1
error: ignoring interface vmbr1. Only one object with attribute 'bridge-vlan-aware yes' allowed.
error: cannot find interfaces: vmbr1

Back in the web gui I edit and the vmbr1 interface and unchecked the "VLAN Aware" option. Now it's activated!
But will VM's still be able to access the different VLANS on this bridge? I will test and found out.
 

aaron

Proxmox Staff Member
Staff member
Jun 3, 2019
1,249
140
63
Have you tried to remove this line
Code:
 auto eno4
and keep the vlan aware setting for vmbr1?
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!