Linode to Proxmox Migration


Well-Known Member
Sep 20, 2012
I have a customer with a legacy application that is still running on CentOS 5.11. I have recommended we clone the VM and bring it in-house on Proxmox and put it behind a firewall to better protect it since CentOS 5 updates ended years ago.

I have managed to boot the Linode in rescue mode and clone ('dd') the various partitions /dev/sda thru /dev/sde. These are using ext3 for the filesystem.

On Proxmox I have copied these images via dd to raw LVM devices on Proxmox but they will not boot. It appears the Linode is using Virtio SCSI (Direct-Access QEMU QEMU HARDDISK 2.5+ PQ: 0 ANSI: 5) for the disk driver but this does not work in Proxmox. I have also tried SATA and IDE for the heck of it but it will not boot using any of those disk types.

If I run a rescue CD from a CentOS 5 it does not see the devices at all. If I use a CentOS 7 Rescue CD, I can see the devices and mount them. I can confirm I have all of files from the original server. However if I do an "fdisk -l" it says "Disk /dev/sda doesn't contain a valid partition table."

Also when looking at the disk in parted it shows the Partition Table as "loop".

Does anyone have any pointers on what I might be missing and how to get this system to boot?

Best regards,
Last edited:
I have also tried SATA and IDE for the heck of it but it will not boot using any of those disk types.
I mean, just to ensure basic things: once you chose SCSI you also edited the SCSI controller to VirtIO?


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!