Latest VE 7.4-X and 8.0.4 not starting containers/VMs at startup

Jedis

New Member
Apr 25, 2023
23
1
1
I verified I still have the setting set to autostart on 3 containers/VMs.

This is shown in the log, but nothing starts. I have to right click each VM to start them. This was previously working before updating to the latest version of VE 7.

Any ideas on how to fix this?
 

Attachments

  • vm1.jpg
    vm1.jpg
    21.8 KB · Views: 13
Hi,
please share the task log (double click on the Start all VMs and Containers) and the output of pveversion -v. Also check your system logs/journal for more information.
 
Hi,
please share the task log (double click on the Start all VMs and Containers) and the output of pveversion -v. Also check your system logs/journal for more information.
"TASK OK"

proxmox_task.jpg

Code:
# pveversion -v
proxmox-ve: 8.0.2 (running kernel: 6.2.16-15-pve)
pve-manager: 8.0.4 (running version: 8.0.4/d258a813cfa6b390)
proxmox-kernel-helper: 8.0.3
pve-kernel-5.15: 7.4-6
proxmox-kernel-6.2.16-15-pve: 6.2.16-15
proxmox-kernel-6.2: 6.2.16-15
pve-kernel-5.15.116-1-pve: 5.15.116-1
pve-kernel-5.15.102-1-pve: 5.15.102-1
ceph-fuse: 17.2.6-pve1+3
corosync: 3.1.7-pve3
criu: 3.17.1-2
glusterfs-client: 10.3-5
ifupdown2: 3.2.0-1+pmx5
ksm-control-daemon: 1.4-1
libjs-extjs: 7.0.0-4
libknet1: 1.26-pve1
libproxmox-acme-perl: 1.4.6
libproxmox-backup-qemu0: 1.4.0
libproxmox-rs-perl: 0.3.1
libpve-access-control: 8.0.5
libpve-apiclient-perl: 3.3.1
libpve-common-perl: 8.0.9
libpve-guest-common-perl: 5.0.5
libpve-http-server-perl: 5.0.4
libpve-rs-perl: 0.8.5
libpve-storage-perl: 8.0.2
libspice-server1: 0.15.1-1
lvm2: 2.03.16-2
lxc-pve: 5.0.2-4
lxcfs: 5.0.3-pve3
novnc-pve: 1.4.0-2
proxmox-backup-client: 3.0.3-1
proxmox-backup-file-restore: 3.0.3-1
proxmox-kernel-helper: 8.0.3
proxmox-mail-forward: 0.2.0
proxmox-mini-journalreader: 1.4.0
proxmox-widget-toolkit: 4.0.9
pve-cluster: 8.0.4
pve-container: 5.0.4
pve-docs: 8.0.5
pve-edk2-firmware: 3.20230228-4
pve-firewall: 5.0.3
pve-firmware: 3.8-2
pve-ha-manager: 4.0.2
pve-i18n: 3.0.7
pve-qemu-kvm: 8.0.2-6
pve-xtermjs: 4.16.0-3
qemu-server: 8.0.7
smartmontools: 7.3-pve1
spiceterm: 3.3.0
swtpm: 0.8.0+pve1
vncterm: 1.8.0
zfsutils-linux: 2.1.13-pve1

Log is attached. From the attached log, Proxmox is showing in its console (from my screenshot in the post above) that it requested to "Start all VMs and Containers" but syslog is showing that it requested to change the status from freeze to request_stop. I had to manually start a container to get it going. This was previously working before I updated to latest 7.4-x. I then updated to latest 8.0-x, and notice the same behavior on 7.4-x.

Any ideas?
 

Attachments

  • startup_proxmox.log
    174.2 KB · Views: 0
Last edited:
What if you go to the Output tab?

Log is attached. From the attached log, Proxmox is showing in its console (from my screenshot in the post above) that it requested to "Start all VMs and Containers" but syslog is showing that it requested to change the status from freeze to request_stop. I had to manually start a container to get it going. This was previously working before I updated to latest 7.4-x. I then updated to latest 8.0-x, and notice the same behavior on 7.4-x.

Any ideas?
So the guests are configured with HA, but the startup request comes in just at the wrong time, while the HA service is starting up, while the services are in freeze state and thus the request is most likely ignored. How many nodes do you have? If you have multiple, were the other ones up already at that time?
 
What if you go to the Output tab?


So the guests are configured with HA, but the startup request comes in just at the wrong time, while the HA service is starting up, while the services are in freeze state and thus the request is most likely ignored. How many nodes do you have? If you have multiple, were the other ones up already at that time?
I have only one node and had HA turned off. Maybe the upgrade turned it on? How do I switch it off on the existing and change the default to off?

I raised an eyebrow when I saw HA, as I never saw that before the upgrade.
 
You can go to Datacenter > HA in the UI and remove the services there. Did you maybe install some third-party script which would add the services to HA?
 
You can go to Datacenter > HA in the UI and remove the services there. Did you maybe install some third-party script which would add the services to HA?
No. I did see the three containers were there, so I deleted the services. It may have been added by one of the Proxmox updates? Not against using HA, but it seems that it's defective and causing a race condition.
 
No. I did see the three containers were there, so I deleted the services. It may have been added by one of the Proxmox updates? Not against using HA, but it seems that it's defective and causing a race condition.
No, there was no change for automatically adding services to HA. The race should only happen if you use a standalone node I think and HA is not really designed for that. Because with multiple nodes, the HA master will be on another node and already be fully started at the point the autostart happens, so it should be able to handle the start request.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!