KVM windows guest time changing

adam.james17

Member
Jan 22, 2018
19
0
6
34
How to fix the kvm guest of windows getting time change every reboot.
if we set internet time or manual time its still change to another timing.
 
* did you set the vm OS-Type to Windows? (otherwise PVE presents the clock as UTC, where Windows expects localtime)
* if not - what kind of time-change do you see? (what time should be set, what time does the machine actually have)?
* please post the vm's config
 
  • Like
Reactions: adam.james17
* yes its selected as windows 2012
* changing time to IST and it auto change back to US time GMT-4
 

Attachments

  • download.png
    download.png
    22.5 KB · Views: 77
Several articles regarding this issue already, including me experiencing it.
 
Hi,

I have just found the solution:
Proxmox handles windows VM by setting "Use local time for RTC" to Default (Enabled for Windows).
In this case, your Proxmox time zone MUST match your windows timeZone.

Otherwise

If you want to mixte timezones in your setup, you MUST set "Use local time for RTC" to No in Proxmox, and TimeZoneInformation to RealTimeIsUniversal in your Windows VMS Register.

By running as administrator:

Bash:
reg add HKLM\SYSTEM\CurrentControlSet\Control\TimeZoneInformation /v RealTimeIsUniversal /t REG_DWORD /d 1

and Voilà !

SOLVED.
 
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!