Kernel panic - system not boot after hard reboot


New Member
Sep 6, 2023
Hi, my proxmox version is 7.4.3.

After the server suddenly hard reboot proxmox starts with an error message:
Kernel Panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

It happens when booting with kernel 5.15.104-1-pve.

I started the system with a different kernel version 5.15.30-2-pve and run update-initramfs -u -k 5.15.104-1-pve but it returned: update-initramfs: Generating /boot/initrd.img-5.15.104-1-pve E: no ldd around - install libc-bin update-initramfs: failed for /boot/initrd.img-5.15.104-1-pve with 1.

How can I fix this problem?
Last edited:
In the end, I solved the problem myself. It was necessary to reinstall the libc-bin package according to instructions. Then I run
update-initramfs -u -k 5.15.104-1-pve


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!