Kein SSH zu LXContainer

Discussion in 'Proxmox VE (Deutsch)' started by Randal Graves, Nov 8, 2018.

  1. Randal Graves

    Randal Graves New Member

    Joined:
    Nov 8, 2018
    Messages:
    2
    Likes Received:
    0
    Hallo zusammen,

    ich betreibe einen reinen Heimserver mit Proxmox. Darüber wollte ich (in LXC) div. weitere Heimserver oder Dienste bereitstellen. Mir ist klar das dies auch über Docker funktionieren würde.
    Ich habe zuerst Network Bridge's für jeden LXC angelegt.

    upload_2018-11-8_11-57-30.png

    Danach habe ich die LXC's erstellt und jedem seine eigene Bridge zugewiesen.

    upload_2018-11-8_11-59-43.png

    Jeder LXC stellt nun einen Dienst im Heimnetzwerk bereit (zB. hugin = nzbget / gjoll = pihole).
    Ich lasse diese 2 auch beim Booten von Proxmox automatisch starten.
    Zuerst hat auch alles gut funktioniert, aber von jetzt auf gleich (ohne das ich bewusst Einstellungen verändert habe), lässt sich "hugin" nicht mehr erreichen.
    Ping auf *.251 funktioniert, SSH einwahl bringt mich allerdings auf den Proxmox Host und nicht in den Container.
    Auch ist nzbget in meinem Netzwerk nicht länger verfügbar.
    Wenn ich die Console aus Proxmox benutze, kann ich mich verbinden und auch ein ifconfig zeigt mir auch die entsprechende IP an. SSH Dienst ist auch gestartet und richtig konfiguriert.

    upload_2018-11-8_12-11-4.png

    Walhall ist die Proxmox Maschine, SSH Einwahl funktioniert.
    hugin ist die für nzbget, SSH Einwahl hat anfangs funktioniert aber jetzt gelange ich bei SSH Einwahl auf Walhall und das Webinterface ist nicht zu länger erreichen.
    yggdrasil ist für Nextcloud, SSH Einwahl hat anfangs funktioniert aber jetzt gelange ich bei Einwahl auf Walhall und das Webinterface ist nicht länger zu erreichen.
    gjoll ist für PiHole, SSH Einwahl funktioniert und das Webinterface ist auch zu erreichen.
    bifrost habe ich zum Test erstellt, SSH Einwahl funktioniert auch nach div Neustarts.

    Dieses Problem hatte ich bereits in der letzten Woche und habe deswegen Proxmox einmal komplett neu installiert.

    Ich hoffe konnte mich einigermaßen verständlich ausdrücken und bin gespannt auf jede Antwort.

    PS: Falls fragen kommen wie "Warum so und nicht so..." ist die Antwort, ich wusste es nicht besser und bin div. Tutorials / Threads und Videos gefolgt :D
     
  2. tschanness

    tschanness Member

    Joined:
    Oct 30, 2016
    Messages:
    266
    Likes Received:
    18
    Du hast der Bridge auf dem Host die IP von hugin gegeben...
     
    Randal Graves likes this.
  3. Randal Graves

    Randal Graves New Member

    Joined:
    Nov 8, 2018
    Messages:
    2
    Likes Received:
    0
    Vielen Dank für deine Antwort.
    Ich habe jetzt die IP's in den Bridges und auch in den LXC's (Beispiel oben net0) entfernt und es klappt alles.
    Das installierte Debian im LXC hat ja die IP in /etc/network/interfaces oder sollte ich lieber das net0 mit einer IP versehen?
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice