[SOLVED] Just updated, no longer booting, stuck at "loading initial ramdisk"


Jan 8, 2019
I've been running Proxmox for the last few months without issue. I applied the latest update last night and now Proxmox refuses to boot any futher than "Loading initial ramdisk"

Naturally I googled what that means and it seems a few people have been stuck at this point before, yet not of the solutions offered were relevant to me (ie. new hardware conflict) or a solution that I'm already using (use legacy mode instead of UEFI)

I'm at a loss as to what is causing this issue now after it's been running so smoothly for months.
Have you tried to boot the previous kernel? Does the issue persist also with that? What hardware are you running on?
Yep, first thing I tried was to use previous kernels. Still no go. I'm running Proxmox on a Gigabyte H270N motheboard with an i5-7500
Boot hangs at "loading initial ramdisk" ... I'm not a debian expert but I left Proxmox on default when installing so I think that would be ext4. Nope, no BIOS update or anything different. I just simply ran the latest update through the Proxmox GUI and then after a reboot it wouldn't start.. I plugged in a monitor to see what the problem was and that's the only thing I can see. No error, nothing .. just stuck at "loading initial ramdisk"
You can try to get to a rescue shell as mentioned by the provided link. If you can't reach a rescue shell your initramfs is probably corrupt.
Assuming it's corrupt as you say since I was unable to boot into rescue shell. Is there a way to reinstall Proxmox without losing all VM and LXC data on the disk?
You can try to boot into the rescue mode from CD, using the proxmox iso.
Just an update: I tried absolutely everything I could think of. As a last resort, I decided to run a system diagnostic. Turns out one single 16GB RAM had decided to give up the ghost, it was throwing over 7 million errors. I wouldn't have believed it if I hadn't seen it for myself. Brand new builds or new modules, sure, I come across faulty RAM many times. Even just removing a stick and putting into another machine, sometimes just the act of moving it from one to another could upset it. but in all my 25+ years of computing, I've never once seen a RAM module throw errors that had been working perfectly undisturbed for almost a year. So there we have it, put in some new RAM and it's up and running again.

Thanks for all your help Chris. I thought I would post an update just in case someone else comes across this problem of their system failing at "loading initial ramdisk" ... check your RAM! "
Thank you for the update, happy to hear that you are up and running again!


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!