JBOD for zfs

Discussion in 'Proxmox VE: Installation and configuration' started by brucexx, Jul 13, 2018.

  1. brucexx

    brucexx Member

    Joined:
    Mar 19, 2015
    Messages:
    116
    Likes Received:
    4
    I have a PVE installed on RAID 1 on Perc h730p - it is not feasible to move it as it is in production with too many VMs etc. I want to use storage replication so I need zfs which does not like RAID controllers in general - that is why I found doing some digging and on this forum. The only option that I see to setup zfs is set the drives in JBOD. I am not sure if anybody has done that on perc h730p maybe there is some additional configuration I missed and/or it performs well in the JBOD mode for the drives I am using for zfs - so far no issues.

    I am aware that I could setup and pass through on the Perc but as I mentioned I cannot move the raid1 primary where the PVE is installed.

    Any advice appreciated.

    Thank you
     
  2. wolfgang

    wolfgang Proxmox Staff Member
    Staff Member

    Joined:
    Oct 1, 2014
    Messages:
    3,560
    Likes Received:
    209
    Hi,

    generally, the main problem is not the Raid it is the cache of the Raid.
    HW Raid raid try to be smart and mask disk access to use their own cache.
    If you use JBOD the cache is will still be used on the most HWRaid cards.
    So there will be the same problems.
     
  3. brucexx

    brucexx Member

    Joined:
    Mar 19, 2015
    Messages:
    116
    Likes Received:
    4
    Is the cache the only issue ?

    I should have started with it but I looked at the Perc h730p documentation and found that there is an option to disable cache for non-raid disks. It is under advanced controller properties. Has anybody done that successfully and can share the results (meaning working well with zfs or not working) ?

    Thank you
     
  4. alexskysilk

    alexskysilk Active Member
    Proxmox VE Subscriber

    Joined:
    Oct 16, 2015
    Messages:
    363
    Likes Received:
    40
    Perc 730s can be used in passthrough mode. its an option in the bios settings. this should be sufficient for jbod use.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice