Issues with Virtio-GL

andrei indreies

New Member
Nov 2, 2023

I have an old pc on which I installed proxmox:
Proxmox version: 8.0
CPU: FX 8350 AMD
Motherboard: MSI760GA-p43
Ram: 16gb ram ddr3
GPU: gtx 550 ti

Even tho my cpu supports virtualization I do not have the settings for IOMMU in my bios so I cannot passthrough any PCI to my guest machines.
So the only way to get 3D acceleration on my linux machines is to use VirtGL (afaik). But I got an issue with it:
my image is looking like this:

Screenshot 2023-11-02 at 13.31.25.png

Vm used: manjaro, ubuntu, popos.
I tried to install mesa on all guest vms -> same result.

this are installed on my proxmox: libgl1 libegl1

The purpose of this machine is to use home assistant and also a linux vm for a virtual workspace, till I will upgrade to i5-13400 next year.

Any thoughts why I get this issue with VirtGL ? It works just fine with virtio but the lag is killing me.
Last edited:


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!