[SOLVED] issue with grub and importing pool?

killmasta93

Renowned Member
Aug 13, 2017
964
56
68
30
Hi,
recently today i got grub error to reboot, i booted into proxmox debug install and got to the command line. I tried importing the pool by this
Code:
zpool import -d /dev

see picture but when i tried to import the pool using the ID i get the insufficient replicas any ideas??
Thank you
 

Attachments

  • 20191029_085814.jpg
    20191029_085814.jpg
    535.4 KB · Views: 10
It seems that you have a RAID10, where one vdev (mirror-1) is not available anymore. With RAID10 the data is split between those two vdevs. If you don't get the second vdev back, then your pool is dead. Check that all disks needed exist and are working properly.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!