[SOLVED] issue restoring from dump?

killmasta93

Renowned Member
Aug 13, 2017
959
56
68
30
Hi
I was wondering if someone could lend me a hand on how come i cannot restore the dump this is the error log
Code:
restore vma archive: lzop -d -c /media/usb/dump/vzdump-qemu-131-2018_12_29-15_44_06.vma.lzo|vma extract -v -r /var/tmp/vzdumptmp11275.fifo - /var/tmp/vzdumptmp11275
CFG: size: 310 name: qemu-server.conf
DEV: dev_id=1 size: 161061273600 devname: drive-virtio0
CTIME: Sat Dec 29 15:44:09 2018
new volume ID is 'zfs-vmdata:vm-134-disk-1'
map 'drive-virtio0' to '/dev/zvol/vmdata/vm-134-disk-1' (write zeros = 0)

** (process:11668): ERROR **: can't open file /dev/zvol/vmdata/vm-134-disk-1 - Could not open '/dev/zvol/vmdata/vm-134-disk-1': No such file or directory
/bin/bash: line 1: 11667 Broken pipe lzop -d -c /media/usb/dump/vzdump-qemu-131-2018_12_29-15_44_06.vma.lzo
11668 Trace/breakpoint trap | vma extract -v -r /var/tmp/vzdumptmp11275.fifo - /var/tmp/vzdumptmp11275
temporary volume 'zfs-vmdata:vm-134-disk-1' sucessfuly removed
TASK ERROR: command 'lzop -d -c /media/usb/dump/vzdump-qemu-131-2018_12_29-15_44_06.vma.lzo|vma extract -v -r /var/tmp/vzdumptmp11275.fifo - /var/tmp/vzdumptmp11275' failed: exit code 133

I by accient installed the vm on my local which is LVM and i was trying to move it to my vmdata storage with is ZFS i tried to move the disk but did not work. So i thought taking a backup and restoring but nothing. any ideas?

This is config of the dump

Code:
()
bootdisk: virtio0
cores: 2
memory: 6000
name: Zeus
net0: virtio=1A:33:3A:D5:02:1D,bridge=vmbr4
numa: 0
ostype: win8
scsihw: virtio-scsi-pci
smbios1: uuid=bd556cc5-73f8-44fe-bbaa-5d62413beae0
sockets: 1
virtio0: local:131/vm-131-disk-1.raw,cache=writeback,size=150G
#qmdump#map:virtio0:drive-virtio0:local:raw:

Thank you
 
Hi,

is your ZFS pool under load? how long it takes to create a zvol?

time zfs create -V150G vmdata/vm-134-disk-1 && ls /dev/zvol/vmdata/vm-134-disk-1

remove the zvol after test
zfs destroy vmdata/vm-134-disk-1
 
  • Like
Reactions: killmasta93
Thanks for the reply, what i did was restoring it on another proxmox box which worked. there's something wrong with my old box which i got to fix updating. Thanks again
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!