[SOLVED] issue import vmdk?

killmasta93

Renowned Member
Aug 13, 2017
959
56
68
30
Hi,
I was wondering if someone could help me on the issue im having. Currently trying to import vmdk to proxmox i tried the following
Code:
 qm importdisk 101 Windows_Server_2012_disk0.vmdk local-zfs
but i got this
zfs error: cannot create 'rpool/data/vm-101-disk-1': volume size must be a multiple of volume block size


any ideas?

Thank you
 
Could be an issue were we do not round up to the next valid ZVol size when allocating the vdisk for the import...
@oguz can you please take a look at this?

As a workaround you could try to import it on another storage and then move the disk over to ZFS?
 
Thanks for the reply, im currently trying to convert the vmdk to vhdx to see if thats the issue, i also tried
Code:
qemu-img convert -O qcow2 Olympus2.vmdk /var/lib/vz/images/100/vm-100-disk-1.qcow2

but had no luck
 
Thanks for the reply, i had to restore on LVM proxmox then backup it up, and restore it on zfs
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!