Is there a way to disable the automatic start of VMs before proxmox boots?

turin231

New Member
Apr 20, 2020
19
1
3
38
I have made a mistake trying to passthrough a NIC that was already used by another VM through a bridge. At restart the host is trying to start both VMs and crashes and i have no access to it either from the web interface or the console. Is there a way to disable the automatic start of the VMs before boot by any chance?
 

oguz

Proxmox Staff Member
Staff member
Nov 19, 2018
4,895
617
118
hi,

if you cannot boot the host at all, you could try booting with a recovery iso and editing the VM configuration in /etc/pve/qemu-server/VMID.conf and remove the onboot parameter to disable that option
 

turin231

New Member
Apr 20, 2020
19
1
3
38
thank you for the reply. I actually managed to boot up by disabling all the networking card. But /etc/pve/qemu-server/VMID.conf seems read only and cannot change this even using root.
 

oguz

Proxmox Staff Member
Staff member
Nov 19, 2018
4,895
617
118
did you replace VMID with the actual ID of your VM? those files aren't readonly under normal circumstances.
 

turin231

New Member
Apr 20, 2020
19
1
3
38
yeah i did.

btw this in a node with a cluster of two if this matters for this case.
 
Last edited:

turin231

New Member
Apr 20, 2020
19
1
3
38
So the issues i have are similar to this: https://forum.proxmox.com/threads/i-o-errors-pve-not-booting.75120/post-343494

The reason i think things go read only is that there is no quorum with the networking disabled.

The problem is that if i disable networking the errors stop - i can boot. If i use pvecm expect 1 to have quorum on the faulty node anything i try to run freezes the console.

I think i might try a debian live iso and try to edit the vm configuration files from there.
 

leesteken

Famous Member
May 31, 2020
1,443
277
83
You might not be able to see the files in /etc/pve if you boot from an iso. Because the problem is caused by PCI passthrough, I suggest editing the boot menu (press the 'e'-key) and removing the intel_iomm=on or amd_iommu=on from the kernel parameters. Then the VMs won't be able to do passthrough and Proxmox should start normally (except for failing to start those VMs).
 
  • Like
Reactions: turin231

turin231

New Member
Apr 20, 2020
19
1
3
38
You might not be able to see the files in /etc/pve if you boot from an iso. Because the problem is caused by PCI passthrough, I suggest editing the boot menu (press the 'e'-key) and removing the intel_iomm=on or amd_iommu=on from the kernel parameters. Then the VMs won't be able to do passthrough and Proxmox should start normally (except for failing to start those VMs).
Thank you that was a great idea (i feel bad for not thinking it earlier). I ended up actually disabling virtulization from the BIOS and indeed the host booted normally so i could remove the incorrect passthrough.
 
Last edited:

Antwan

New Member
Nov 27, 2021
11
0
1
38
if you access it a the server with a screen and keypad log in and use

qm list

then

nano /etc/pve/qemu-server/VMID.conf
swapping vmid for the number of the device
go down to booton change 1 to 0
on them all if your not sure
and reboot

Hope that helps

i thin
 
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!