Is it possible to disable rpcbind (port 111) and how to do it?

Pilat

New Member
Aug 21, 2010
29
0
1
Is it possible to disable rpcbind (port 111) and how to do it?

Can I disable rpcbind (port 111) and how do I do this?
I get abuse on port 111, and this is the only port that I need to close, even though I do not use it (rpcbind and NFS).
 

manu

Proxmox Staff Member
Mar 3, 2015
806
64
28
Either block it with the firewall or disable it with
systemctl stop rpcbind
systemctl disable rpcbind
 
  • Like
Reactions: popallo

robingr

Member
Sep 5, 2017
9
1
8
31
I want to bring this up again.
As we are hosting at Hetzner we are used to get the usual notifications from the BSI about rpcbind running on a fresh server.
In the past it was a one-shot to just disable and stop the service as described above.
But now i received the warning the third time and I stopped and disabled the service after the first notification.
It seems that either a crontab or something starts it automatically.

The server has a uptime of 32 days as I am writing.

Unbenannt.png

Any Ideas?
 

cheeseandcereal

New Member
Dec 18, 2018
6
0
1
36
I noticed there is an rpcbind service, socket, and target all in systemd which can end up turning each other on. Try disabling, then stopping all 3:

Code:
systemctl disable rpcbind.target
systemctl disable rpcbind.socket
systemctl disable rpcbind.service
systemctl stop rpcbind.target
systemctl stop rpcbind.socket
systemctl stop rpcbind.service
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!