[SOLVED] ipv6-only: pveproxy does not bind to ipv6 address

Nov 19, 2019
6
0
1
I recently made a fresh install from a PVE 6.0 ISO on an empty box. I decided to run that box as ipv6-only. Installation went through smoothly. All IP address infos I entered during the installation went correctly into /etc/network/interfaces.

Unfortunately the pveproxy does not bind to [::]:8006. How do I tell him otherwise?

Code:
auto lo
iface lo inet loopback

iface eno1 inet6 manual

auto vmbr0
iface vmbr0 inet6 static
    address fc::2
    netmask 64
    gateway fc::1
    bridge_ports eno1
    bridge_stp off
    bridge_fd 0

iface eno2 inet6 manual
iface eno3 inet6 manual
iface eno4 inet6 manual

Code:
State             Recv-Q            Send-Q                       Local Address:port Peer Address:port
LISTEN            0                 128                                0.0.0.0:111                               0.0.0.0:*
LISTEN            0                 128                              127.0.0.1:85                                0.0.0.0:*
LISTEN            0                 128                                0.0.0.0:22                                0.0.0.0:*
LISTEN            0                 100                              127.0.0.1:25                                0.0.0.0:*
LISTEN            0                 128                                   [::]:111                                  [::]:*
LISTEN            0                 128                                   [::]:22                                   [::]:*
LISTEN            0                 128                                      *:3128                                    *:*
LISTEN            0                 100                                  [::1]:25                                   [::]:*
LISTEN            0                 128                                      *:8006                                    *:*

proxmox-ve: 6.0-2 (running kernel: 5.0.15-1-pve)
pve-manager: 6.0-4 (running version: 6.0-4/2a719255)
pve-kernel-5.0: 6.0-5
pve-kernel-helper: 6.0-5
pve-kernel-5.0.15-1-pve: 5.0.15-1
ceph-fuse: 12.2.11+dfsg1-2.1
corosync: 3.0.2-pve2
criu: 3.11-3
glusterfs-client: 5.5-3
ksm-control-daemon: 1.3-1
libjs-extjs: 6.0.1-10
libknet1: 1.10-pve1
libpve-access-control: 6.0-2
libpve-apiclient-perl: 3.0-2
libpve-common-perl: 6.0-2
libpve-guest-common-perl: 3.0-1
libpve-http-server-perl: 3.0-2
libpve-storage-perl: 6.0-5
libqb0: 1.0.5-1
lvm2: 2.03.02-pve3
lxc-pve: 3.1.0-61
lxcfs: 3.0.3-pve60
novnc-pve: 1.0.0-60
proxmox-mini-journalreader: 1.1-1
proxmox-widget-toolkit: 2.0-5
pve-cluster: 6.0-4
pve-container: 3.0-3
pve-docs: 6.0-4
pve-edk2-firmware: 2.20190614-1
pve-firewall: 4.0-5
pve-firmware: 3.0-2
pve-ha-manager: 3.0-2
pve-i18n: 2.0-2
pve-qemu-kvm: 4.0.0-3
pve-xtermjs: 3.13.2-1
qemu-server: 6.0-5
smartmontools: 7.0-pve2
spiceterm: 3.1-1
vncterm: 1.6-1
zfsutils-linux: 0.8.1-pve1
 
Ah, of course. (Thought about it before writing my post but simply forgot it.)

Code:
127.0.0.1 localhost.localdomain localhost
fc::2 pve.example.com pve

# The following lines are desirable for IPv6 capable hosts

::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts

I even tried something like this:
Code:
::ffff:127.0.0.1 pve
 
Hmm - looks ok - what's the output of:
* `uname -n`
* `ping6 $(uname -n)`
* `hostname`
* `hostname -f`
* `cat /etc/pve/.members`
 
Code:
# uname -n
pve

# ping6 $(uname -n)
PING pve(pve.example.com (fc::4)) 56 data bytes
64 bytes from pve.example.com (fc::4): icmp_seq=1 ttl=64 time=0.045 ms

# hostname
pve

# hostname -f
pve.example.com

# cat /etc/pve/.members
{
"nodename": "pve",
"version": 0
}
 
IIRC the '*:8006' should cover both address families (though this depends on some sysctls)
sorry for not seeing this before.

Thanks for reporting back!
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!