IPv6 Broken on Thunderbolt Interfaces


Active Member
Aug 8, 2023
I have 3 intel NUCs

I wanted to use fabricd/ospfv6 and IPv6 addresses for a 3 node ring / mesh network. I had many many issues trying to do this:
  • ICMPv6 worked ok - so i can v6 ping just fine....
  • ssh wouldn't work over IPv6 on the thunderbolt interface (but IPv4 was fine)
  • setting up second ceph node would fail with communication issues
I repeated all my tests on a two-node point to point setup with only one cable between each node to eliminate the ring from being an issue.

I confirmed this was not a firewall issue by installing additional ethernet adapters in the 3 NUCs to have a parallel IPv6 network (albeit 2.5gbe instead of 20gbe). This worked perfectly and confirmed (i think) i am not making any mistakes with the firewall.

I thought this was all because i am brand new to proxmox (it still might be the reason!)

But after more testing it appears this is 100% an issue with IPv6 and thunderbolt adapters on Proxmox VE 8 (i don't know if this a proxmox issue or underlying debian issue)

I will switch to IPv4 for now as IPv6 wasn't really doing anything for me other than i default to IPv6 in my network at this juncture for purpose of learning.

I still have the repro if anyone is interested in me collecting any information.
Last edited:
  • Like
Reactions: ualex


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!