Internal server error when browsing https://localhost/quarantine/spam/manage.htm

kwm30

New Member
Aug 15, 2007
4
0
1
Received the following error when only 2 people are browsing the web interface... If one user logs out of the i/f and all is good. Is this an imposed limit in the trial version??? Internal Server Error The server encountered an internal error or misconfiguration and was unable to complete your request. Please contact the server administrator, postmaster@wnfg31.nz.fujitsu.com and inform them of the time the error occurred, and anything you might have done that may have caused the error. [1839]ERR: 24: Error in Perl code: DBI connect('dbname=Proxmox_ruledb','postgres',...) failed: FATAL: sorry, too many clients already at /usr/share/perl5/Proxmox/Utils.pm line 390 Apache Embperl 2.2.0 [Wed Aug 15 13:53:58 2007] Product: mail gateway 2.0 (trial version) hardware: compaq SFF P4 3.2GB, 2GB RAM, SATA 80GB Using the product behind a firewall as a mail proxy before handing off to our 2nd mail proxy, Only used for in-comming mail. Regards km
 

martin

Proxmox Staff Member
Staff member
Apr 28, 2005
716
1,132
144
Received the following error when only 2 people are browsing the web interface... If one user logs out of the i/f and all is good. Is this an imposed limit in the trial version??? Internal Server Error The server encountered an internal error or misconfiguration and was unable to complete your request. Please contact the server administrator, postmaster@wnfg31.nz.fujitsu.com and inform them of the time the error occurred, and anything you might have done that may have caused the error. [1839]ERR: 24: Error in Perl code: DBI connect('dbname=Proxmox_ruledb','postgres',...) failed: FATAL: sorry, too many clients already at /usr/share/perl5/Proxmox/Utils.pm line 390 Apache Embperl 2.2.0 [Wed Aug 15 13:53:58 2007] Product: mail gateway 2.0 (trial version) hardware: compaq SFF P4 3.2GB, 2GB RAM, SATA 80GB Using the product behind a firewall as a mail proxy before handing off to our 2nd mail proxy, Only used for in-comming mail. Regards km

hi km,
no, this is not a limitation of the trial version - a trial is fully functional. you wrote in a separate posting that you changed a view things on your installation so maybe this caused the error. can you describe all the things you changed?

for fast debugging, we can offer you doing a remote SSH login (just open the ssh port for our IP: 213.129.239.114)and send the login credentials fro support@proxmox.com.
 

jweber

New Member
Dec 21, 2007
1
0
1
I have not altered anything on my configuration and I am having the same issue on my server. Can you please advise me on how to fix this issue. Also is there an ETA on eDirectory authentication for the web front end?
 

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
15,520
906
163
I have not altered anything on my configuration and I am having the same issue on my server. Can you please advise me on how to fix this issue. Also is there an ETA on eDirectory authentication for the web front end?

hi,

do you use the latest version? 2.1 - 2294. if not please upgrade.

what kind of hardware (ram, hdd system, cpu)?

what does proxperf report when the system is not under load?
(see also http://www.proxmox.com/forum/showthread.php?t=296)
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!