[SOLVED] Internal NAT - No out traffic

SunBlack

Member
Jun 22, 2017
14
1
23
53
Hi all,

I had to setup a fresh installation of Proxmox. As we don't have enough IPv4 adresses, we had used a NAT on our old installation. But this works now only partially. I can connect from outide to my VM via port 20222, but the VM can't reach any internet adress (e.g. for updating the system). Any thing I missed?

Code:
auto lo
iface lo inet loopback

iface eno1 inet manual

iface eno2 inet manual

iface eno3 inet manual

iface eno4 inet manual

auto vmbr0
iface vmbr0 inet static
        address  x.x.x.16
        netmask  255.255.255.192
        gateway  x.x.x.1
        bridge-ports eno1
        bridge-stp off
        bridge-fd 0

auto vmbr1
iface vmbr1 inet static
        address  192.168.0.1
        netmask  24
        bridge-ports none
        bridge-stp off
        bridge-fd 0
        post-up echo 1 > /proc/sys/net/ipv4/ip_forward
        post-up iptables -t nat -A PREROUTING -i vmbr0 -p tcp --dport 20222 -j DNAT --to 192.168.0.202:22
        post-down iptables -t nat -D PREROUTING -i vmbr0 -p tcp --dport 20222 -j DNAT --to 192.168.0.202:22

vmbr1 is showed as online in UI of Proxmox 6.1

//EDIT: Ok, disabling firewall on the network of the VM worked. But they is blocking outgoing, but not incoming traffic?
 
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!