[SOLVED] Intel X550-T2 SR-IOV failed to enable


Active Member
Jul 4, 2019
I am trying to make SR-IOV work in my system.

I got Athlon 200GE running on Asrock X470-ITX, and made sure in BIOS IOMMU and SR-IOV are both enabled. I made the change in grub and I had no problem passing the PCI devices with usual pass-through method.

To enable SR-IOV, I added a file ixgbe.conf under /etc/modprobe.d, as the NIC uses ixgbe driver.
Then, inside the ixgbe.conf, I added a line options ixgbe max_vfs=4

However, when I try to load it by executing rmmod ixgbe;modprobe ixgbe,
it threw the following error:
pci ixgbe 0000:01:10.0: unknown header type 7f, ignoring device
ixgbe 0000:01:00.0 0000:01:00.0 (uninitialized): Failed to enable PCI sriov -5
pci ixgbe 0000:01:10.1: unknown header type 7f, ignoring device
ixgbe 0000:01:00.1 0000:01:00.1 (uninitialized): Failed to enable PCI sriov -5​

I then also tried to update the firmware to latest, but it didn't help.
Any ideas are appreciated.
Last edited:


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!