Installed Failed - Unable to create bios_boot partition


Active Member
Apr 27, 2019
I've installed proxmox on 10 servers now but 1 is giving me fits. Every time I try to install I get the following screen.


The error on the F3 screen is as follows. Sorry for the screenshot but can't copy/paste.


If it matters this is on a UCS platform. After the first few failures I did boot off of DBAN and did a complete wipe of that drive without error so I'm fairly sure it's good.
* Did you choose to install on '/dev/sdf' with ext4 (or xfs)?
* could you boot a linux live-cd on that server and get the partition table of /dev/sdf after a failed install-attempt?

I did install on /dev/sdf with ext4. I didn't change any of the defaults. I'll download a live CD and get back to you. Is fdisk -l /dev/sdf sufficient for your needs or would you like more details?
The output of `parted /dev/sdf print` additionally might be nice (since i'm kind of used to it :)

As an alternative you could also wipe the disk once (dd if=/dev/zero of=/dev/sdf bs=64M) and try installing again (in debug mode)
(if the issue happens again you can use `gdisk -l /dev/sdf` from the debug-shell you get dropped into)

The live cd (slax) changed the drive mapping from sdf to sda but with that said here is the output you asked for.


I'm wiping this again with dd and will reinstall once it finishes in the debug mode so I have more opportunities for troubleshooting. Will follow back with more details if it fails again.
The msdos partition table seems rather odd after installing with the PVE-ISO (pve has been using GPT-partitioning since at least 5.2 (probably quite a bit longer)).
Maybe this could somehow be related to the Cisco UCS? (sadly don't have any experience with that platform and google gives quite some mixed results as to what it does and what not)
- if the other servers are also UCS - maybe compare the Firmware/BIOS/... Settings?

- Else try to create a gpt partition table on the disk in slax:
* sgdisk -Z /dev/sda (wipe partition table and create a new one)
sgdisk -a1 -n1:34:2047 -t1:EF02 /dev/sda                                        
sgdisk -n2:1M:+512M -t2:EF00 /dev/sda                                           
sgdisk -n3:513M:0 -t3:8E00 /dev/sda
is pretty much what the installer does

Does this work?
dd completed without issue (didn't capture output). The sgdisk commands are also successful.


Below is the partition table after the sgdisk commands above.


I'm going to proceed with debug mode install right now. Will see how it goes.

Thanks for the help!
The messages with "The kernel is still using the old partition table" might be a hint to the problem ...
(parted output still speaks of a msdos partition table and the gdisk command should have created a gpt table)

if the install indeed does fail - please capture the output of `dmesg` in the last debug shell
Something does seem to be bad wrong with this server or the flash filesystem is locked somehow. New findings

Removed all discs from JBOD. They don't even show up any more in the installer(s).
Removed every boot source in the BIOS other than the "CiscoFlash" option
Tried to install ubuntu server. It hangs on partitioning.
In the RAID utility for the flash drives which has a RAID1 mirror created did a full wipe
* I've already done this via DD & DBAN prior
I walked away during a reboot and it tried to boot from a pre-install RHEL. This boggles the mind...this is not PXE booted!

Sorry but I didn't capture that dmesg output but I'm fairly confident it's not a proxmox issue.
Something does seem to be bad wrong with this server or the flash filesystem is locked somehow.
These problems are always hard to debug :/

Please update the thread if you find out what the root cause was - Thanks!


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!