Installation stuck right after "EFI boot mode detected"

Psyonico

New Member
Jun 28, 2023
3
0
1
I just downloaded the Proxmox VE 8 ISO and burned it to a usb drive using Etcher (I'm on a linux system, so no Rufus). the Install Proxmox option comes up, and when I select it, I get stuck with the below image on my screen. I've let it sit for about 15 minutes and nothing happens. Any ideas?
 

Attachments

  • Proxmox install.jpg
    Proxmox install.jpg
    557.5 KB · Views: 70
After a few tests, I went into the "Advanced Options" category and chose the command line nomodset installer and that seems to have fixed it.
 
I have the same issue when I try to install Proxmox VE 8.1. Tried with GUI, Terminal, GUI Debug Mode, Terminal Debug mode.

Motherboard: ASUS TUF B550-Plus
CPU: AMD Ryzen 3 3200g
GPU: Nvidia Geforce 710 1G

Tried also with iGPU and dedicated GPU, no difference.

Has anyone an idea, why it gets stuck?
 
Ok, I will give it a try.
Just checking if Debian 12 is installing correctly.
So far it looks ok. Are there any disadvantages if I first install debian 12 as stated in the howto and then install Proxmox VE afterwards?
 
OK, after installing Proxmox and doing the reboot:

Code:
apt install proxmox-default-kernel

systemctl reboot

The system is stuck while booting:

Loading Linux 6.5.11-8-pve ...
Loading initial ramdisk ...

:(
 
Installiation of PVE 7.4 is working fine so far, I will try the update now. But I have doubts that this will work, tbh.
 
you can upgrade to 8.1 then pin previous kernel.
check if you just lost the console screen, by connect to PVE over the WebUI.
 
Ok, installing 7.4-3 (latest 7.4 ISO I found), then updating to 7.4-17 worked.
After that, I checkt with pve7to8 if all requirements are in place. Then followed the upgrading procedure from tho HowTos.
After the reboot it got stuck agein at:

Code:
Loading Linux 6.5.11-8-pve ...
Loading initial ramdisk ...

But kept in mind:
"check if you just lost the console screen"

After a while the IP was reachable again and I checked pve7to8 again.

One warning was mentioned:
WARN: System booted in uefi mode but grub-efi-amd64 meta-package not installed, new grub versions will not be installed to /boot/efi! Install grub-efi-amd64.

So I installed the grub-efi-amd64:

Code:
apt install grub-efi-amd64

and did a final reboot.
After that the system was booting without loosing the console and everything seems to be ok now. Thanks @_gabriel.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!