Install of nodejs and npm very slow (very high IO delay)

DST73

Member
Apr 22, 2023
40
0
6
Hi,

I have created a new CT but if I try to install npm it is VERY slow..... running now for almost 30 min
I have noticed that this isn't only on the new created but on others as well.

Looks like I have a very high IO delay
1698494515294.png

I have two drives.
1698494551569.png
the first drive I use for all my containers and backup
I have noticed that on my second drive the LVM is very full
1698494620574.png
How can I see, what is inside?

Could that be the reason why installing anything takes very long? Not only npm. For example I install webmin on some of my containers and that takes very long too.


Thank you!
 
Your Samsung SSD uses QLC flash memory, which becomes slower than an old HDD if you write to them for a long time. Lots of threads (with disappointed people) on this forum about QLC drives.
 
I found an advice to install iotop
Looks like my "Home Assistant" kvm is causing a high IO.
Could that be the problem ?


1698497760881.png
 
Hi,
a little update.
I switch to a new SSD and the IO delay is totally gone..
Is there anything I can do with my old disk?
Tried to reinitialize it and use it as backup but that caused as expected the high delay again.
Do I have to throw the disk in the trash?

Thanks!
 
Ok, tried my fist backup to then new SSD and the IO-deplay is back
Looks like it is only gone during the normal use.

It even cause the system to write the cpu graph :rolleyes:

1698918440499.png

Code:
NFO: starting new backup job: vzdump 201 --storage ext_pve --compress zstd --node pve --remove 0 --mode snapshot --notes-template '{{guestname}}'
INFO: Starting Backup of VM 201 (lxc)
INFO: Backup started at 2023-11-02 10:44:23
INFO: status = running
INFO: CT Name: docker
INFO: including mount point rootfs ('/') in backup
INFO: mode failure - some volumes do not support snapshots
INFO: trying 'suspend' mode instead
INFO: backup mode: suspend
INFO: ionice priority: 7
INFO: CT Name: docker
INFO: including mount point rootfs ('/') in backup
INFO: starting first sync /proc/7970/root/ to /mnt/pve/ext_pve/dump/vzdump-lxc-201-2023_11_02-10_44_23.tmp
cannot remove directory for /mnt/pve/ext_pve/dump/vzdump-lxc-201-2023_11_02-10_44_23.tmp: Read-only file system at /usr/share/perl5/PVE/VZDump.pm line 1202.
ERROR: Backup of VM 201 failed - command 'rsync --stats -h -X -A --numeric-ids -aH --delete --no-whole-file --sparse --one-file-system --relative '--exclude=/tmp/?*' '--exclude=/var/tmp/?*' '--exclude=/var/run/?*.pid' /proc/7970/root//./ /mnt/pve/ext_pve/dump/vzdump-lxc-201-2023_11_02-10_44_23.tmp' failed: exit code 11
INFO: Failed at 2023-11-02 10:47:15
cp: cannot stat '/mnt/pve/ext_pve/dump/vzdump-lxc-201-2023_11_02-10_44_23.log': Input/output error
INFO: Backup job finished with errors
TASK ERROR: job errors


the backup ends with an error
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!