increasing fs.inotify.max_user_instances?

nttec

Active Member
Jun 1, 2016
95
0
26
40
I was trying to increase my fs.inotify.max_user_instances with this

Code:
sysctl fs.inotify.max_user_instances=2048
sysctl -p

but I still end up with 1024 when I do

Code:
ulimit -n

I run pvedaemon restart

but it doesnt do anything.

what am I missing here?

the reason why I want try to increase this is because my host server reboot and upon checking the logs I got error.

Code:
updating service status from manage failer: Too many open files
[libqb] error: couldn't create file from mmap
[libqb] error: qb_rb_open:pve2-request-1903-39010-1022: Too many open files (24)
[libqb] error: shm connection FAILED: Too many open files (24)
[libqb] error: Error in connection setup (1903-39010-1022): Too many open file (24)
 
Last edited:
I guess, you want to check/set the file.max value, if you just need it temporarily then you could do a 'ulimit -n 2048'.
https://askubuntu.com/a/460687
 
Same as you tried with the inotify setting above.
 
In my experience, systemd is notorious for ignoring or overriding sysctl settings. You may need to edit /etc/systemd/system.conf and change the relevant setting, e.g., DefaultLimitNOFILE as described in systemd.exec

Changes should be picked up by issuing 'systemctl daemon-reexec'
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!