[SOLVED] Incorrect link inside email after hostname change

_KrEdEnS_

Member
Nov 12, 2020
6
0
6
22
Hi,
when I changed hostname form
Code:
old.hostname.com
to
Code:
new.hostname.com
, inside email which PBS sending after for example verification data I see
Code:
new.new.hostname.com
. How can repair it to see
Code:
new.hostname.com
after "Please visit the web interface for further details:" message?

Places where I replaced hostname:
  • /etc/hosts
  • /etc/hostname
  • /etc/postfix/main.cf
 
Hi!
our FQDN in the email is build using the system hostname + (if available) the "search" parameter in the `/etc/resolv.conf` file.

For example on my instance:
Code:
$ hostname
pikachu
$ cat /etc/resolv.conf
search caterpie.com
nameserver 192.168.2.15
so the fqdn in the email is: pikachu.caterpie.com
 
Hi!
our FQDN in the email is build using the system hostname + (if available) the "search" parameter in the `/etc/resolv.conf` file.

For example on my instance:
Code:
$ hostname
pikachu
$ cat /etc/resolv.conf
search caterpie.com
nameserver 192.168.2.15
so the fqdn in the email is: pikachu.caterpie.com
Hi,
it works, nice know how email build link.
When I am changing hostname search parameter i changed to full "new.hostname.com" so why i saw "new.new.hostname.com" inside email. After correction its ok!
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!