i440fx GPU passthrough


Well-Known Member
Aug 7, 2017
I would like to utilize PCI passthrough of my video card using the default i440fx machine instead of q35.
i440fx will support this and is known to have some benefits where q35 and nvidia have issues on specific cards.

When I start the VM I receive the following error at start:
q35 machine model is not enabled at /usr/share/perl5/PVE/QemuServer.pm line 3528

Can I bypass this requirement?

I set the vm config 'machine: q35' and hoped the the args line would overrule and get past this error with no joy.

machine: q35
args: -machine pc

Is there any way I can get past this error?
can you post the complete config? i guess you enabled pcie for the hostpci device, which can only work on q35 (since i440fx does not have a pcie bus)


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!