I reported an error when upgrading PVE using apt update and apt dist upgrade. Do I need to stop the cluster?

ggea

New Member
Jun 28, 2023
29
1
3
This is the error output when I execute apt update and apt dist upgrade
 
Last edited:
root@zmc-pve7:~# apt update
Err:1 http://mirrors.aliyun.com/debian bullseye InRelease
Could not connect to 192.168.2.8:80 (192.168.2.8). - connect (111: Connection refused)
Err:2 http://deb.debian.org/debian buster InRelease
Could not connect to 192.168.2.8:80 (192.168.2.8). - connect (111: Connection refused)
Err:3 https://mirrors.ustc.edu.cn/proxmox/debian/ceph-quincy bullseye InRelease
Could not connect to 192.168.2.8:443 (192.168.2.8). - connect (111: Connection refused)
Err:4 https://mirrors.nju.edu.cn/proxmox/debian bullseye InRelease
Could not connect to 192.168.2.8:443 (192.168.2.8). - connect (111: Connection refused)
Err:5 http://mirrors.aliyun.com/debian bullseye-updates InRelease
Unable to connect to 192.168.2.8:http:
Err:6 http://mirrors.aliyun.com/debian-security bullseye-security InRelease
Unable to connect to 192.168.2.8:http:
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
46 packages can be upgraded. Run 'apt list --upgradable' to see them.
W: Failed to fetch http://mirrors.aliyun.com/debian/dists/bullseye/InRelease Could not connect to 192.168.2.8:80 (192.168.2.8). - connect (111: Connection refused)
W: Failed to fetch http://mirrors.aliyun.com/debian/dists/bullseye-updates/InRelease Unable to connect to 192.168.2.8:http:
W: Failed to fetch http://mirrors.aliyun.com/debian-security/dists/bullseye-security/InRelease Unable to connect to 192.168.2.8:http:
W: Failed to fetch http://deb.debian.org/debian/dists/buster/InRelease Could not connect to 192.168.2.8:80 (192.168.2.8). - connect (111: Connection refused)
W: Failed to fetch https://mirrors.ustc.edu.cn/proxmox/debian/ceph-quincy/dists/bullseye/InRelease Could not connect to 192.168.2.8:443 (192.168.2.8). - connect (111: Connection refused)
W: Failed to fetch https://mirrors.nju.edu.cn/proxmox/debian/dists/bullseye/InRelease Could not connect to 192.168.2.8:443 (192.168.2.8). - connect (111: Connection refused)
W: Some index files failed to download. They have been ignored, or old ones used instead.
 
root@zmc-pve7:~# apt update
Err:1 http://mirrors.aliyun.com/debian bullseye InRelease
Could not connect to 192.168.2.8:80 (192.168.2.8). - connect (111: Connection refused)
Err:2 http://deb.debian.org/debian buster InRelease
Could not connect to 192.168.2.8:80 (192.168.2.8). - connect (111: Connection refused)
Err:3 https://mirrors.ustc.edu.cn/proxmox/debian/ceph-quincy bullseye InRelease
Could not connect to 192.168.2.8:443 (192.168.2.8). - connect (111: Connection refused)
Err:4 https://mirrors.nju.edu.cn/proxmox/debian bullseye InRelease
Could not connect to 192.168.2.8:443 (192.168.2.8). - connect (111: Connection refused)
Err:5 http://mirrors.aliyun.com/debian bullseye-updates InRelease
Unable to connect to 192.168.2.8:http:
Err:6 http://mirrors.aliyun.com/debian-security bullseye-security InRelease
Unable to connect to 192.168.2.8:http:
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
46 packages can be upgraded. Run 'apt list --upgradable' to see them.
W: Failed to fetch http://mirrors.aliyun.com/debian/dists/bullseye/InRelease Could not connect to 192.168.2.8:80 (192.168.2.8). - connect (111: Connection refused)
W: Failed to fetch http://mirrors.aliyun.com/debian/dists/bullseye-updates/InRelease Unable to connect to 192.168.2.8:http:
W: Failed to fetch http://mirrors.aliyun.com/debian-security/dists/bullseye-security/InRelease Unable to connect to 192.168.2.8:http:
W: Failed to fetch http://deb.debian.org/debian/dists/buster/InRelease Could not connect to 192.168.2.8:80 (192.168.2.8). - connect (111: Connection refused)
W: Failed to fetch https://mirrors.ustc.edu.cn/proxmox/debian/ceph-quincy/dists/bullseye/InRelease Could not connect to 192.168.2.8:443 (192.168.2.8). - connect (111: Connection refused)
W: Failed to fetch https://mirrors.nju.edu.cn/proxmox/debian/dists/bullseye/InRelease Could not connect to 192.168.2.8:443 (192.168.2.8). - connect (111: Connection refused)
W: Some index files failed to download. They have been ignored, or old ones used instead.
root@zmc-pve7:~# apt dist-upgrade
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Calculating upgrade... Done
The following NEW packages will be installed:
pve-kernel-5.15.107-2-pve
The following packages will be upgraded:
base-files debian-archive-keyring grep isc-dhcp-client isc-dhcp-common libavahi-client3 libavahi-common-data libavahi-common3 libc-bin libc-l10n libncurses6 libncursesw6 libnvpair3linux libpve-common-perl libpve-http-server-perl libpve-rs-perl libtinfo6 libunbound8
libuutil3linux libxml2 libzfs4linux libzpool5linux linux-libc-dev locales ncurses-base ncurses-bin ncurses-term openvswitch-common openvswitch-switch postfix proxmox-backup-client proxmox-backup-file-restore proxmox-widget-toolkit pve-edk2-firmware pve-firewall
pve-firmware pve-ha-manager pve-i18n pve-kernel-5.15 qemu-server spl traceroute tzdata zfs-initramfs zfs-zed zfsutils-linux
46 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 203 MB of archives.
After this operation, 402 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Err:1 http://mirrors.aliyun.com/debian bullseye/main amd64 base-files amd64 11.1+deb11u7
Could not connect to 192.168.2.8:80 (192.168.2.8). - connect (111: Connection refused)
Err:2 http://mirrors.aliyun.com/debian bullseye/main amd64 grep amd64 3.6-1+deb11u1
Unable to connect to 192.168.2.8:http:
Err:3 https://mirrors.nju.edu.cn/proxmox/debian bullseye/pve-no-subscription amd64 libnvpair3linux amd64 2.1.11-pve1
Could not connect to 192.168.2.8:443 (192.168.2.8). - connect (111: Connection refused)
Err:4 https://mirrors.nju.edu.cn/proxmox/debian bullseye/pve-no-subscription amd64 libpve-rs-perl amd64 0.7.6
Unable to connect to 192.168.2.8:https:
Err:5 http://mirrors.aliyun.com/debian bullseye/main amd64 ncurses-bin amd64 6.2+20201114-2+deb11u1
Unable to connect to 192.168.2.8:http:
Err:6 http://mirrors.aliyun.com/debian bullseye/main amd64 libc-bin amd64 2.31-13+deb11u6
Unable to connect to 192.168.2.8:http:
Err:7 http://mirrors.aliyun.com/debian bullseye/main amd64 ncurses-base all 6.2+20201114-2+deb11u1
Unable to connect to 192.168.2.8:http:
Err:8 https://mirrors.nju.edu.cn/proxmox/debian bullseye/pve-no-subscription amd64 libpve-common-perl all 7.4-1
Unable to connect to 192.168.2.8:https:
Err:9 https://mirrors.nju.edu.cn/proxmox/debian bullseye/pve-no-subscription amd64 libpve-http-server-perl all 4.2-3
Unable to connect to 192.168.2.8:https:
Err:10 https://mirrors.nju.edu.cn/proxmox/debian bullseye/pve-no-subscription amd64 libuutil3linux amd64 2.1.11-pve1
Unable to connect to 192.168.2.8:https:
Err:11 https://mirrors.nju.edu.cn/proxmox/debian bullseye/pve-no-subscription amd64 libzfs4linux amd64 2.1.11-pve1
Unable to connect to 192.168.2.8:https:
Err:12 http://mirrors.aliyun.com/debian bullseye/main amd64 debian-archive-keyring all 2021.1.1+deb11u1
Unable to connect to 192.168.2.8:http:
Err:13 http://mirrors.aliyun.com/debian bullseye/main amd64 libncurses6 amd64 6.2+20201114-2+deb11u1
Unable to connect to 192.168.2.8:http:
Err:14 http://mirrors.aliyun.com/debian bullseye/main amd64 libncursesw6 amd64 6.2+20201114-2+deb11u1
Unable to connect to 192.168.2.8:http:
Err:15 http://mirrors.aliyun.com/debian bullseye/main amd64 libtinfo6 amd64 6.2+20201114-2+deb11u1
Unable to connect to 192.168.2.8:http:
Err:16 http://mirrors.aliyun.com/debian bullseye/main amd64 tzdata all 2021a-1+deb11u10
Unable to connect to 192.168.2.8:http:
Err:17 http://mirrors.aliyun.com/debian bullseye/main amd64 isc-dhcp-client amd64 4.4.1-2.3+deb11u2
Unable to connect to 192.168.2.8:http:
Err:18 http://mirrors.aliyun.com/debian bullseye/main amd64 isc-dhcp-common amd64 4.4.1-2.3+deb11u2
Unable to connect to 192.168.2.8:http:
Err:19 https://mirrors.nju.edu.cn/proxmox/debian bullseye/pve-no-subscription amd64 libzpool5linux amd64 2.1.11-pve1
:https:
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
 
Check you mirror configuration and DNS settings: It seems that your traffic is directed to 192.168.2.8, which refuses connections.
 
Hello, we have found the problem. Thank you. The reason is that I have set up a proxy here

root@zmc-pve10:~# cat /etc/apt/apt.conf.d/76pveproxy
Acquire::http::proxy "http://192.168.2.8";
 
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!