I have a annoying bar with dots in my Ubuntu VM screen


Active Member
Aug 25, 2017
I have a annoying constant bar in my Ubuntu VM screen.
The red and white dots are constantly going from left to right.
How do i get rid of this?

How do i get rid of this?

Generally don't use graphic output on a server virtualization platform like Proxmox VE. For this special purpose, there exist Desktop virtualization products like VirtualBox which do a much better job at provding a good desktop feeling.

Your error ist most probably caused by some framebuffer issue, try to play around with different display settings:

  • Like
Reactions: GKmst
I agree 100% i do use Proxmox for cli server systems only. This one GUI system I use to download large files. Since the Proxmox server is running 24/7 I can shutdown other systems and go to sleep while the download is still going.

Your tip changing the display settings did the trick problem solved.

Thank you!
Glad it solved your issue.

If you want a GUI that feels a little bit different, you can look at x2go. It's a terminal server like software that works on a cli-only server, but enables you to start, detach and reattach later. It works like a charm. Another good experience is to use SPICE as display and a SPICE client on your desktop. But be aware, it works with windows, but not all features are available.
x2go is new to me and sounds interesting I will check that out.

I tested Spice but its not working and i gave it up.
Also, with display mode set to Spice it gave me this weird bar with dots i talked about earlier.
I could not connect to the Spice graphic server for some reason i couldn't figured it out.

Now i changed the display mode without Spice and the weird bar is gone.
Since spice wasn't working I'm using now the noVNC console option that works well.

Thank you for the tips
I'm going to check out x2go, that sounds promising.
Same problem here. It occurs on Ubuntu with Gnome and mostly when using SPICE, sometimes even when using "Default" display with noVNC. Sometimes rebooting helps, sometimes not.
Not using SPICE is not an option, as noVNC misses SPICE USB ports, Audio, clipboard, ... and the lag is annoying, at least for day to day work.
Is it a Proxmox bug? Or a Gnome one? Or Ubuntu?
and the lag is annoying, at least for day to day work.

You know that PVE is a server virtualization platform and not a desktop one? If you really need desktop experience, use a decent desktop virtualization product.

The one time I used SPICE, i did it with Debian (XFCE) without any problems to implement file sharing for PVE. It worked flawlessly and I was also able to play wine games over the internet including audio with a maximum delay of 1 second.
Yes, you're right. Debian works (even with GNOME), XFCE works, MATE, Windows, ... it's just Ubuntu with GNOME. Sometimes.

And yes, I know PVE is a server virtualization platform. I just wanted to say: Of course you can switch from SPICE to VNC, if that (sometimes) circumvents the problem, but you might have a reason for using SPICE. And it would be nice if the dots are a bug that someone can fix.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!