I can't login to my Proxmox Web Interface!

naupe

Member
Apr 8, 2019
36
3
13
36
Recently I set up my Proxmox for port 443. Unfortunately, since I've done so, I'm unable to login to the Proxmox GUI!

I've tried logging in as root and a Guest Admin Account I created. Both give me back the following message:

Code:
Login failed. Please try again

I can login to both account when SSHing to the Proxmox Server in Putty, it's just the Web Interface that is giving me this issue. I've never had Login issues until now.
 
Last edited:

naupe

Member
Apr 8, 2019
36
3
13
36
Alright, so NOW the Proxmox Web Interface comes up! Here is what I've done, and I don't know if it's a longterm solution:

Code:
wget http://download.proxmox.com/debian/pve/dists/stretch/pve-no-subscription/binary-amd64/libpve-access-control_5.1-12_amd64.deb
dpkg -i libpve-access-control_5.1-12_amd64.deb
Since I downloaded an older version of libpve-access-control, and now I went back to the previous (and more updated) version.

Code:
apt --fix-broken install
apt-get install pve-manager
pve-manager has unmet dependencies apparently:

Code:
The following packages have unmet dependencies:
libpve-guest-common-perl : Breaks: qemu-server (< 6.1-19) but 5.0-56 is to be installed
libpve-storage-perl : Breaks: qemu-server (< 6.1-14) but 5.0-56 is to be installed
pve-cluster : Breaks: qemu-server (<= 6.0-13) but 5.0-56 is to be installed
pve-ha-manager : Depends: qemu-server (>= 6.0-15) but 5.0-56 is to be installed
pve-manager : Depends: qemu-server (>= 6.2-17) but 5.0-56 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

But THIS was what I installed to allow me to login to the PVE Web Manager again:
Code:
apt-get install libspice-server1

At the end however, I was given the following warning:
Code:
W: (pve-apt-hook) !! WARNING !!
W: (pve-apt-hook) You are attempting to remove the meta-package 'proxmox-ve'!
W: (pve-apt-hook)
W: (pve-apt-hook) If you really want to permanently remove 'proxmox-ve' from your system, run the following command
W: (pve-apt-hook)       touch '/please-remove-proxmox-ve'
W: (pve-apt-hook) run apt purge proxmox-ve to remove the meta-package
W: (pve-apt-hook) and repeat your apt invocation.
W: (pve-apt-hook)
W: (pve-apt-hook) If you are unsure why 'proxmox-ve' would be removed, please verify
W: (pve-apt-hook)       - your APT repository settings
W: (pve-apt-hook)       - that you are using 'apt full-upgrade' to upgrade your system
E: Sub-process /usr/share/proxmox-ve/pve-apt-hook returned an error code (1)
E: Failure running script /usr/share/proxmox-ve/pve-apt-hook

I have NO idea why! I am quite worried there is a lot of misconfigurations with my Proxmox VE 5.4-2 (which I know is old, but I'm not quite sure what I need to do to upgrade from 5.4-2 to 6.X).
 
Last edited:

fiona

Proxmox Staff Member
Staff member
Aug 1, 2019
2,686
564
118
Hi,
what is the output of pveversion -v and how does your /etc/apt/sources.list and files in /etc/apt/sources.list.d look like?
 

naupe

Member
Apr 8, 2019
36
3
13
36
Thank you for the reply @Fabian_E !

Output of pveversion -v:
Code:
proxmox-ve: 5.4-2 (running kernel: 4.15.18-10-pve)
pve-manager: 5.4-15 (running version: 5.4-15/d0ec33c6)
pve-kernel-4.15: 5.4-19
pve-kernel-4.15.18-30-pve: 4.15.18-58
pve-kernel-4.15.18-10-pve: 4.15.18-32
corosync: 3.0.4-pve1~bpo9
criu: 2.11.1-1~bpo90
glusterfs-client: 3.8.8-1
ksm-control-daemon: 1.2-2
libjs-extjs: 6.0.1-2
libpve-access-control: 5.1-12
libpve-apiclient-perl: 2.0-5
libpve-common-perl: 5.0-56
libpve-guest-common-perl: 2.0-20
libpve-http-server-perl: 2.0-14
libpve-storage-perl: 5.0-44
libqb0: 1.0.5-1~bpo9+2
lvm2: 2.02.168-pve6
lxc-pve: 3.1.0-7
lxcfs: 3.0.3-pve1
novnc-pve: 1.0.0-3
proxmox-widget-toolkit: 1.0-28
pve-cluster: 5.0-38
pve-container: 2.0-42
pve-docs: 5.4-2
pve-edk2-firmware: 1.20190312-1
pve-firewall: 3.0-22
pve-firmware: 2.0-7
pve-ha-manager: 2.0-9
pve-i18n: 1.1-4
pve-libspice-server1: 0.14.1-2
pve-qemu-kvm: 3.0.1-4
pve-xtermjs: 3.12.0-1
qemu-server: 5.0-56
smartmontools: 6.5+svn4324-1
spiceterm: 3.0-5
vncterm: 1.5-3
zfsutils-linux: 0.7.13-pve1~bpo2

Contents of the /etc/apt/sources.list file:
Code:
deb http://ftp.us.debian.org/debian buster main contrib

deb http://ftp.us.debian.org/debian buster-updates main contrib

# security updates
deb http://security.debian.org buster/updates main contrib

# For PVE 5.4 Upgrade
deb http://download.proxmox.com/debian buster pve-no-subscription

Files within the /etc/apt/sources.list.d folder:
Code:
-rw-r--r-- 1 root root 64 Nov 25 15:30 corosync3.list
-rw-r--r-- 1 root root 68 Nov 25 15:36 pve-enterprise.list
 

fiona

Proxmox Staff Member
Staff member
Aug 1, 2019
2,686
564
118
So you already configured the repositories for PVE 6. You should switch back to stretch instead of buster for now and fix up the installation. Please run apt update and apt dist-upgrade afterwards. Do not continue with the upgrade if it still wants to remove proxmox-ve. PVE ships its own pve-libspice-server1 which conflicts with libspice-server1, so you cannot install the latter.

Only after apt is happy again, try upgrading to PVE 6, following this guide.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!