I can't add Tape Library as Changer

owear

New Member
Jul 4, 2023
6
0
1
Hello there!

I have PBS 3.0-1 as VM in PVE 7.4-15
also I have DELL TL4000 +sas+HBA with PCI Passthrough

root@pvebackup:~# ls -l /dev/tape/by-id
total 0
lrwxrwxrwx 1 root root 9 Jul 4 09:34 scsi-1068075780 -> ../../st1
lrwxrwxrwx 1 root root 10 Jul 4 09:34 scsi-1068075780-nst -> ../../nst1
lrwxrwxrwx 1 root root 9 Jul 4 09:34 scsi-1068075780-sg -> ../../sg1
lrwxrwxrwx 1 root root 9 Jul 4 09:38 scsi-1068075831 -> ../../st0
lrwxrwxrwx 1 root root 10 Jul 4 09:38 scsi-1068075831-nst -> ../../nst0
lrwxrwxrwx 1 root root 9 Jul 4 09:38 scsi-1068075831-sg -> ../../sg0
lrwxrwxrwx 1 root root 9 Jul 4 09:34 scsi-35000e1115ab69007 -> ../../st1
lrwxrwxrwx 1 root root 10 Jul 4 09:34 scsi-35000e1115ab69007-nst -> ../../nst1
lrwxrwxrwx 1 root root 9 Jul 4 09:34 scsi-35000e1115ab69007-sg -> ../../sg1
lrwxrwxrwx 1 root root 9 Jul 4 09:38 scsi-35000e1115ab6900a -> ../../st0
lrwxrwxrwx 1 root root 10 Jul 4 09:38 scsi-35000e1115ab6900a-nst -> ../../nst0
lrwxrwxrwx 1 root root 9 Jul 4 09:38 scsi-35000e1115ab6900a-sg -> ../../sg0


I can add Single Drive and I see it in GUI, but I can't add Changer into PBS, what's wrong?
 
what does
Code:
proxmox-tape changer scan
show?

also the complete output of 'dmesg' would be interesting
 
what does
Code:
proxmox-tape changer scan
show?

also the complete output of 'dmesg' would be interesting
proxmox-tape changer scan
Nothing!


[ 1599.508022] st 2:0:33:0: Attached scsi generic sg1 type 1
[ 1791.487158] st 2:0:32:0: SCSI device is removed
[ 1843.498152] scsi 2:0:32:0: Sequential-Access IBM ULT3580-HH5 H971 PQ: 0 ANSI: 6
[ 1843.514994] st 2:0:32:0: Attached scsi tape st0
[ 1843.515018] st 2:0:32:0: st0: try direct i/o: yes (alignment 4 B)
[ 1843.515250] st 2:0:32:0: Attached scsi generic sg0 type 1
 
it seems that the 'HBA" is a raid controller in reality? at least it loads the megaraid_sas driver fromt he kernel
are you certain that this raid card supports changers (this does not have to be the case)
can you try with a normal hba (non-raid) ?
 
it seems that the 'HBA" is a raid controller in reality? at least it loads the megaraid_sas driver fromt he kernel
are you certain that this raid card supports changers (this does not have to be the case)
can you try with a normal hba (non-raid) ?
The same situation, I see only drives, not Changer!
HBA is H200 DELL, true HBA without RAID
 
The same situation, I see only drives, not Changer!
HBA is H200 DELL, true HBA without RAID
mhmm... can you post the dmesg with the HBA again? the last dmesg did not contain a single info about the changer, so not even the kernel sees it.
maybe there is some setting on the dell directly or a firmware upgrade there?
 
I'm back!
Hello there!

But I still have the same problem((

I have the lastest version of your sw Backup Server 3.0-4
 

Attachments

  • dsmeg.pdf
    113.7 KB · Views: 4
as i said the kernel does not see the changer at all... how did you connect the library? is there any configuration you can do on the changer to make it visible to the host?

EDIT: also i see you use a raid controller. does that support tape libraries? if not, could you try with an HBA instead?
 
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!