hugepages causes network failure in VM


Well-Known Member
Aug 2, 2018

I wasn't sure if I should post this under Networking or Configuration. I've got an interesting issue. When I add "hugepages: any" to two of my VM's (WS 2016, Debian 10), the network never connects. Debian complains it can't bring the network interface up, WS2016 just says "Identifying...", not getting a DHCP response.

Removing "hugepages: any" allows both to boot / connect normally.

I've tried removing and re-adding NICs, adding secondary NICs, the fault persists. I've tried cloning the VM (not that I expected that to help), but the issue persists.

The weird thing is I have two other VM's, both W10 Desktops that I can remove /readd "hugepages: any" to without issue. Luckily, these are the two VM's that need the setting as they both have GPU's passed through and hugepages seems to help with DPC latency issues.

Any thoughts or help appreciated!
Could you post your VM conf files and possibly a 'pveversion -v'?

Also, have you tried manually setting the hugepage size, i.e. 'hugepages: 2' and 'hugepages: 1024'?


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!