HPE Proliant doesn't boot after install

bzg

Member
Jan 4, 2020
10
1
8
41
Hi team,

I spent few days and still can not resolve my issue, I hope somebody can help me. We have only HPE Proliant servers with P820/P410i raid controller cards, both cards was firmwared so they are now in HBA mode configured. The install can be done without errors, the problem is that Proliant servers can not boot from disk that are connected to HBA mode Raid cards!

First tought was to boot the system with the installer CD in rescue mode, but that way the root pool wasnt found.

Second was to install the system on USB drive, but I'm not sure its a good idea because of the cluster filesystem, has a lot of small writes.

The third thing was to install grub on USB pendrive or if needed put the whole /boot on the USB (for redundancy two USB pendrive in mdraid??). The /boot is not changing so much so the pendrive should be reliable. But I don't have idea how should be done this with the installer?! Maybe in debug mode?

The last idea to replace the P820/P410i cards, but i'm not sure if other vendors cards will work in Proliants? Can be changed the boot controller? And which card will work wirh ZFS/Ceph for sure? LSI SAS 9207-8i?

Thanks in advance,
Zoltan
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!