[SOLVED] How to set up a vm using on a RBD storage


New Member
Sep 19, 2019
Hello guys,
I've been trying to import VMs recently, I got the .vmdk file and I followed the tutorial given on Proxmox Wiki but I still have questions. When I create a VM within Proxmox GUI, I can choose my pve_pool (rbd disk shared by my three nodes) ressource as a storage disk.
But when importing a VM via the shell, when using the command
dd if=win2003-pve.vmdk of=/dev/VG_iscsi/vm-102-disk-1
What path can I give to the "of=" when I know that the pool is not a local disk storage ?
I tried using the following command:
dd if=W10RDP-pve.vmdk of=pve_pool\:vm-102-disk-0
but I keep getting the error
Booting from Hard Disk...
Boot failed: not a bootable disk
Is it because of the path I gave or because of the .vmdk file ?
(I'm currently doing the tutorial solution to the problem of the error at boot using vmware-diskmanager but I was wondering if it couldn't be something else !)

Thank you in advance for your answers !
Are you using 'dd' directly to import the disk? Take a look at qm importdisk (see 'man qm' for details).
If I have a .vmdk, I only have to use the qm importdisk command and I can start the VM created earlier ?
Because I keep having :
Nothing to boot: No such file or directory
No bootable device
Boot the new VM with a live media and investigate the restored disk, mainly the boot sector and partition, compare its content with a working VM.
Is it a Windows or Linux guest? If Linux, which distribution?
Does the original use UEFI?
Please post your VM config ('qm config <vmid>').
I tried booting it using UEFI but it says that the Windows needs to be repaired but it can't be done via the Windows GUI
It is a Windows 10 (64 bits) guest.
Here is my VM config:
root@pve01:~# qm config 102
boot: cdn
bootdisk: ide0
cores: 2
ide0: pve_pool:vm-102-disk-0,size=50G
memory: 2048
name: W10RDP
net0: e1000=42:FF:39:9C:DD:37,bridge=vmbr0,firewall=1
numa: 0
ostype: win10
scsihw: virtio-scsi-pci
smbios1: uuid=3be7f339-e250-4748-89b5-74d89f79b94e
sockets: 1
unused1: pve_pool:vm-102-disk-1
vmgenid: accda6b5-786b-4664-9cb4-9491caa9d589
Ok I managed to start the VM imported with the OVMF (UEFI) BIOS and it works perfectly while still not working with SeaBios... Is it a problem if I keep it as OVMF ?


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!