How to reset password as root password has changed?

eiger3970

Active Member
Sep 9, 2012
273
3
38
Hi,
I can't login to my rebuilt Proxmox server so I'm trying to reset the root password.
I follow these steps
Using GRUB, you can manually edit the proposed menu entry at boot time. To do so, when GRUB is presenting the menu list (you might need to press ESC first), follow those instructions:

  • use the arrows to select the boot entry you want to modify.
  • press e to edit the entry
  • use the arrows to go to kernel line
  • press e to edit this entry
  • at the end of the line add the word single
  • press ESC to go back to the parent menu
  • press b to boot this kernel
The kernel should be booting as usual (except for the graphical splash screen you might be used to), and you will finally get a root prompt (sh#).
from http://www.debuntu.org/how-to-recover-root-password-under-linux-with-single-user-mode/

but there's no option to see the 'kernel' line?

Any help on how to reset the password so I can login to the server?
 

eiger3970

Active Member
Sep 9, 2012
273
3
38
Hi Nyquist,
good karma to you, that helped.
Quick comment on a discrepancy...init=/bin/sh on the screenshot says init=/bin/s\h
I then pressed Ctrl+x and the next screen gave an error:
Loading, please wait...
/bin/sh: 0: can't access tty; job control turned off
#

Looks like I might have another faulty HDD?
 

nyquist

Member
Aug 7, 2013
9
1
23
Hey eiger,
Look at the screenshots on the link I sent. Those lines are exactly what that guy got when running those commands. You can go ahead and follow the next steps after you get that message.

Regards,
 

eiger3970

Active Member
Sep 9, 2012
273
3
38
Yes, tried to follow the link http://c-nergy.be/blog/?p=1777, however on step 3 part 2, the GRUB doesn't let me type in mount -o remount rw /

The text I see is:
1i8f' [141] terminated by signal 9 (Killed)
udevd[98]: '/sbin/modprobe -b pci:v00008086d000027DFsv00001849sd000027DFbc01sc01
i8a' [109] terminated by signal 9 (Killed)


Target filesystem doesn't have requested /bin/s.
BusyBox v1.20.2 (Debian 1:1.20.0-7) multi-call binary.

Usage: switch_root [-c /dev/console] NEW_ROOT NEW_INIT [ARGS]

Free initramfs and switch to another root fs:
chroot to NEW_ROOT, delete all in /, move NEW_ROOT to /,
execute NEW_INIT. PID must be 1. NEW_ROOT must be a mountpoint.

-c DEV Reopen stdio to DEV after switch

Kernel panic - not syncing: Attempted to kill init!
Pid: 1, comm: busybox veid: 0 Not tainted 2.6.32-20-pve #1
Call Trace:
[<ffffffff8151210b>] ? panic+0xa0/0x160
[<ffffffff81070b1c>] ? do_exit+0x8fc/0x900
[<ffffffff81070eb2>] ? do_group_exit+0x42/0xa0
[<ffffffff81070f27>] ? sys_exit_group+0x17/0x20
[<ffffffff8100b182>] ? system_call_fastpath=)x16/0x1b
 

eiger3970

Active Member
Sep 9, 2012
273
3
38
Well, it finally worked and the password has been reset.
I woud like to check if Proxmox has any access logs and password change logs to see how the password keeps changing?
Maybe someone knows a path location to folders storing these logs?
Also, one of my virtual servers on proxmox has also had its password changed, which I cannot log into anymore.
I am unable to reset the virtual server in Proxmox as the Proxmox console for the virtualserver won't load? I lodged a new forum thread re this http://forum.proxmox.com/threads/16...d-cannot-access-via-console?p=85162#post85162.
 
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!