[SOLVED] How to get proper CRs in editors when using 'pct enter VMID' or 'pct console VMID'?

May 18, 2019
root@pvhost~# pct enter 100
root@pvguest~# visudo



I would like to avoid installing sshd on guests and manage them only via 'pct enter VMID'. But it is really inconvenient to use 'visudo' or nano on anything, because it looks as above and the cursor behaves erratically.

So I am not sure if I need to force tty for 'pct enter' or there is another way around it. How to keep these rectangles from showing up??
`script /dev/null` gets me a TTY, but the funky CRs (rectangles) are still there. I guess it is not TTY related. how to go any further is beyond me.

the question then is how to enter a container using `pct enter VMID` or `pct console VMID` from an SSH session and get proper CRs inside an editor? Both nano and vim have messed up CRs. If I use the console on the host to pct enter I do not get the messy chars.

Is the only way to SSH into the container?

I'm going to leave this here for reference (as I understand pct is just a frontend to lxc standard cmds)

Last edited:
UPDATE: I believe the problem is related to WSL. The funky chars do not occur when I enter the container via a Putty SSH session.

Since Putty sucks, I tried different Windows terminals:

- ComEmu
- Cmder
- ExtraTerm

The last one is the only one that worked to use WSL's bash to `pct enter` a container and have proper display.
Last edited:


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!