How to export rpool on a running system


Active Member
Aug 27, 2019
I have been trying to solve an issue when trying to backup a VM, would get an error.
I tried restart the node, now that the VM is not running it can't find the original attached disk.
it shows
Download TASK ERROR: timeout: no zvol device link for 'vm-201-disk-0' found after 300 sec found.

It was suggested to review this thread
One suggestion that resolved their issue was exporting the zfs pool.
The pool for me which is on local-zfs is on the rpool.
When I try to zpool export rpool and zpool export -f rpool
I get busy signals only.
Please help.
Thank you.
I'm convinced that it's not possible to export (as in unmount) the root filesystem while Linux is running. Maybe you can rescue boot via the Proxmox installer, import -f rpool and then export rpool?
I solved the issue but probably not in The best way. I restored the VM from a back instead. Hopefully I don’t run into that issue again.
Last edited:


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!