[SOLVED] How can i disable /var/tmp from being used when uploading .ISO files?


Renowned Member
Jan 7, 2015
Hello, My PVE rpool is on a small 128GB M.2 2242 SSD, and i use a enterprise U.2 SSD for everything not related to rpool.

I have disabled local and local-zfs in Datacenter storage. Then i have created the corresponding storage on the datacenter SSD.

However, when i upload a .ISO file, it first gets written to /var/tmp on the rpool, and then copied to the datacenter SSD. Is there any way to disable this, to reduce unnecessary writes to the M.2 SSD?

One forum post suggested setting Content to empty on local, but i'm unable to do that from the GUI (content box turns red and prevents from pressing OK)

I have also tried adding tmpdir: /zpool_800G/tmp/ to /etc/vzdump.conf m but that seemed to have no effect. Is there any other solutions to this?


I'm still surprised Proxmox uses /var/tmp instead of /tmp because ISO uploads don't need to survive a reboot (the main reason for /var/tmp to exist). If it used /tmp, you could simply use a tmpfs for it.
Thank you @Neobin , i'll mark this as solved, since this issue is getting attention from developers, and it's likely it will be improved in the future.
hi @nomizfs, I believe this bug is still open/outstanding right?

I have my Proxmox instance on the latest version, and I still run into this...

For now, I use the tmp directory as a workaround..

Is there any visibility in when this will be resolved?


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!