hostrsapubkey: value does not match the regex pattern

stylus

New Member
Jul 8, 2020
6
0
1
28
Hi,

I have the following error from the moment I try to integrate my server into the cluster ...
400 Parameter verification failed. hostrsapubkey: value does not match the regex pattern


Cluster.conf :

master: 1
fingerprint AB:2D:7E:23:5F:38:D9:A9:CA:4B:E6:B3:C7:01:50:24:C8:0F:5C:D1:A5:56:3C:81:A3:E8:50:B0:E3:26:11:B1
hostrsapubkey AAAAB3NzaC1yc2EAAAADAQABAAABAQDI97uG2h15pU959X/RQMQ0LGiqH922gJlmciOKauin5zJLglpdrtX1Lz6L0EhkBElnAzSgId9ZREyAj5YmgMQCN/fGhqD3JWuXey2PvEHnerCqF3zIkyWBPK9rZ7bDYBx8+kra8pZdl8/e+2MWmhqLj20WgTGXu/lAktdWGUWjXw0xkFhaBvhn7NoI1PFOo0vbocLq/S+etI7w9S+rzAoVjZppN3xVse9Jj00s0JLv2tZuIZ/qIAvVEhSiJ57GQlyVqmkR+t6LIEICoLnEQCmyq4vY7UJymysmpGsYOwtdunqIRYmU+vm/3kmEyVFShVG+d9K9BEffSk5huEHOLIJF
ip ........
maxcid 1
name relais
rootrsapubkey AAAAB3NzaC1yc2EAAAADAQABAAABAQC/sDUMadt6CixAd1RX/qcQVFOrb97nW5Qj9p3aiyOpUIKC+QB8LFJM24Xx9h+PFejxslCGXi6qh4QLEpof1RYkjAJ54q+vAdo8Ma+UsrzYqnhxatvjESPqZatz68hQsRU7+RMVciJQV7raDx8E1/l2g8nc127LcYIAZbClmXBTUmt4SN5AILKA8IlQmoo6zRIfD2MDy1d70rr2gR4NqMcKzv+0gQYrCgRtCX4T/9AIFN4/UO7mRsVsE7oDdQtURF+ZMIInkRN1/Y2zlv9+y/jlUeLjdIsq6R7Z5TFBYey4DdLKuT7kC0zpSzAwwaivsFD2AAgJuy6XXYR2Mtq8XjWn
 

t.lamprecht

Proxmox Staff Member
Staff member
Jul 28, 2015
4,459
1,160
164
South Tyrol/Italy
shop.proxmox.com
Hi
I have the following error from the moment I try to integrate my server into the cluster ...
What version is in use here (pmgversion -v) and how did you setup that system, from a PMG official ISO, container template, on top of Debian?
 

stylus

New Member
Jul 8, 2020
6
0
1
28
proxmox-mailgateway: 6.4-1 (API: 6.4-4/1c8a73c7, running kernel: 5.4.30-1-pve)
pmg-api: 6.4-4
pmg-gui: 2.4-3
pve-kernel-5.4: 6.4-3
pve-kernel-helper: 6.4-3
pve-kernel-5.4.119-1-pve: 5.4.119-1
pve-kernel-5.4.30-1-pve: 5.4.30-1
clamav-daemon: 0.103.2+dfsg-0+deb10u1
libarchive-perl: 3.3.3-1
libjs-extjs: 6.0.1-10
libjs-framework7: 4.4.7-1
libpve-apiclient-perl: 3.1-3
libpve-common-perl: 6.4-3
libpve-http-server-perl: 3.2-3
libxdgmime-perl: 0.01-5
lvm2: 2.03.02-3
pmg-docs: 6.4-1
pmg-log-tracker: 2.2.0-1
postgresql-11: 11.12-0+deb10u1
proxmox-mini-journalreader: 1.1-1
proxmox-spamassassin: 3.4.6-1
proxmox-widget-toolkit: 2.5-6
pve-firmware: 3.2-4
pve-xtermjs: 4.7.0-3
zfsutils-linux: 2.0.4-pve1

with PMG official ISO
 

stylus

New Member
Jul 8, 2020
6
0
1
28
however my new server (node) is not using the same version proxmox-mailgateway: 7.0-1
 

t.lamprecht

Proxmox Staff Member
Staff member
Jul 28, 2015
4,459
1,160
164
South Tyrol/Italy
shop.proxmox.com
however my new server (node) is not using the same version proxmox-mailgateway: 7.0-1
Those are not exactly compatible for clustering beside during upgrade of a whole setup from 6.4 to 7.x, where the cluster mirror service is stopped.

What would be your use case here?
 

t.lamprecht

Proxmox Staff Member
Staff member
Jul 28, 2015
4,459
1,160
164
South Tyrol/Italy
shop.proxmox.com
  • Like
Reactions: Stoiko Ivanov

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!