Hard Disk disapeared after moving to another storage


Apr 7, 2020

i tried to move a disk from a local storage to a ceph pool


I don't know if that succeeds or not (i expect it did not succeed). Starting that machine results in:

Could not open '/dev/pve/vm-103-disk-0': No such file or directory


This particular machine does no longer boot.

Where is the disk expected to be? Still, on local-lvm or on myssdpool in ceph? and how can i fix it to point that vm to it's new hdd location?

regards, armin
what does the task log of the Move Disk operation say? What is your pveversion -v? If the disk got moved, but the configuration was not updated correctly, qm rescan --vmid 103 should add the other disk as an unused one, and you can then attach the unused one and detach the current one, to fix the configuration (also might need to adapt the Boot order in the VM's Options tab afterwards). If the rescan command doesn't add a disk, what does lvs say?
task log of the Move Disk is gone

pveversion -v


qm rescan --vmid 103


the vm configuration did not change, so hard disk is still not found, same error remains ...

any ideas where that disk got lost? is it possible to browse local-lvm? maybe there might be the old disk? or is it possible to browse ceph pool to look for the moved disk?

can it really be that a disk disapears after moving from local to ceph?
i finally found the images lying on a different node in a 3-node proxmox cluster setup by:
root@pve-schmidhuber-110:~# pvesm list local-lvm
Volid                   Format  Type             Size VMID
local-lvm:vm-103-disk-0 raw     images    53687091200 103

then, i created a fresh vm on that particular node ("schmidhuber-110") by manually setting all configuration options from original machine (vmid 103) to new vm (vmid 105). as 103 was pretty close to default i just had to set o/s type according to original machine.

afterwards, i looked up harddisk config by

root@pve-schmidhuber-110:/etc/pve/nodes/pve-schmidhuber-120/qemu-server# cat 103.conf | grep 103
ide0: local-lvm:vm-103-disk-0,size=50G

i tried to exactly copy harddisk config from old to new vm by:

root@pve-schmidhuber-110:/etc/pve/nodes/pve-schmidhuber-120/qemu-server# cat 103.conf | grep 103 >> /etc/pve/qemu-server/105.conf
root@pve-schmidhuber-110:/etc/pve/nodes/pve-schmidhuber-120/qemu-server# vi /etc/pve/qemu-server/105.conf

and removed new harddisk, created by vm creation above.

then, i could start new vm with old disk.

so, i recovered that disk by creating a new vm on same node and adding that disk to configuraton.

thanks for help!


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!