Hanging on ''-bash: exit:". Can't get out. Please help... Nvidia passthrough.


New Member
Dec 20, 2022
Hi, good Chicago morning.
During my nvidia passthrough install this happened. For the love of every existing deity I can not get out of it... Can someone help, please. What are my options.
Of course, I have no backup and SSL and shell provide the same output with cursor not allowing me to type in any codes. I have rebooted multiple times with the same result outcome in my terminal. It is a headless install with remote access on home network.1697898209996.png
Hi, sorry for the late reply. Yes, ssh closes immediately after the login as root. I do not have any other users setup.
Is your VM autostarting that does the passthrough? If so, deactivate the autstart and reboot again.
Try connecting with sftp/winscp and see if that works.
Hi, I think I misunderstood and thought that it was possible to log in to the main server setup. In my case, the "hanging" one is the one that all the VMs (100) and LXC containers (201, 202, 203) are running on - the "babuserver" on the image below. Shutting it down shuts the whole system down...
Therefore no login is possible.
Yes, I have minimal experience so I apologize for possibly naive questions and explanations. Nevertheless, this setup was running for me trouble-free for the last year and a half until I recently tried to make some changes to my Nvidia passthrough.1698066533026.png
Returning to my question. If I boot from USB and go into rescue mode, how can I access the root on "babuserver" to use nano editor? Thank you for your help.
Returning to my question. If I boot from USB and go into rescue mode, how can I access the root on "babuserver" to use nano editor? Thank you for your help.
Just run the rescue system on the PVE install disk. It'll automatically mount your system so that you can make changes.
Believe it or not I am back with the same problem. I just left it running without logging in for all this time, since November, because my VM and CTs were working ok. Now I took another approach and wanted to fix the problem by booting from USB and going into the rescue mode. I am able to do it but after typing in my login and password, for a brief second it works and immediately kicks me out to login prompt again...

Login through the SSH gives me same result, kicking me back to login prompt.

My GUI on a different PC on the network is still showing : 1712284139971.png
basically I am stuck. Any ideas please how to stop this -bash: -exit: ...

Thank you, looking forward to ideas.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!