[SOLVED] Handling of physical disk attached to VM

Ivan Dimitrov

Active Member
Jul 14, 2016
Hi, I am not sure if this is a bug or missing feature but basically no disk operations are possible with attached disk to a VM. The main issue are:
- backup fails
INFO: starting new backup job: vzdump 783 --notes-template '{{guestname}}' --node hyper-convergence --remove 0 --storage transient-bkp --mode stop
INFO: Starting Backup of VM 783 (qemu)
INFO: Backup started at 2022-06-27 09:47:04
INFO: status = stopped
INFO: backup mode: stop
INFO: ionice priority: 7
INFO: VM Name: w10-desktop
INFO: include disk 'scsi1' '/dev/disk/by-id/ata-Samsung_SSD_840_Series_S14GNEBCC06723E' 244198584K
INFO: include disk 'efidisk0' 'vm-store:vm-783-disk-0' 1M
INFO: creating Proxmox Backup Server archive 'vm/783/2022-06-27T07:47:04Z'
INFO: starting kvm to execute backup task
INFO: started backup task '570a9015-a8ec-4130-bf71-4780c2e91f18'
INFO: efidisk0: dirty-bitmap status: created new
INFO: scsi1: dirty-bitmap status: created new
INFO:   0% (120.0 MiB of 232.9 GiB) in 3s, read: 40.0 MiB/s, write: 40.0 MiB/s
INFO:   0% (212.0 MiB of 232.9 GiB) in 5s, read: 46.0 MiB/s, write: 38.0 MiB/s
ERROR: job failed with err -5 - Input/output error
INFO: aborting backup job
INFO: stopping kvm after backup task
ERROR: Backup of VM 783 failed - job failed with err -5 - Input/output error
INFO: Failed at 2022-06-27 09:47:12
INFO: Backup job finished with errors
TASK ERROR: job errors

- disk cloning fails:
unable to parse volume ID '/dev/disk/by-id/ata-Samsung_SSD_840_Series_S14GNEBCC06723E' (500)

My thinking is - if the attached disk is seen as raw device, it should be possible to execute all the operations that are possible with other RAW devices. Alternatively the attached disks should be excluded from the operations they do not support.

Here is VM config:
cat /etc/pve/qemu-server/783.conf
agent: 1,fstrim_cloned_disks=1
audio0: device=intel-hda,driver=spice
bios: ovmf
boot: order=scsi1
cores: 6
cpu: host
efidisk0: vm-store:vm-783-disk-0,size=1M
machine: q35
memory: 12288
name: w10-desktop
net0: virtio=C6:3C:24:1F:69:7B,bridge=vmbr0
numa: 0
ostype: l26
scsi1: /dev/disk/by-id/ata-Samsung_SSD_840_Series_S14GNEBCC06723E,discard=on,iothread=1,size=244198584K,ssd=1
scsihw: virtio-scsi-single
smbios1: uuid=6aea4e73-757e-4c21-ba3b-9b4468b1c00c
sockets: 1
spice_enhancements: videostreaming=all
tablet: 1
usb0: host=10c4:ea60
vga: qxl
vmgenid: c020906c-6d21-4f51-a844-0006aeff26ed
can you check the syslog for the time that the backup failed?
That log is a bit short: Jun 27 10:13:05 hyper-convergence ... till Jun 27 10:13:15 hyper-convergence ...
This is how long it takes for the job to fail. You can see the start and end messages:
Jun 27 10:13:05 hyper-convergence pvedaemon[2818450]: INFO: Starting Backup of VM 783 (qemu)
Jun 27 10:13:15 hyper-convergence pvedaemon[2818450]: ERROR: Backup of VM 783 failed - job failed with err -5 - Input/output error
It seems that either your disk or controller are failing. Try to read the disk "dd if=/dev/sdh of=/dev/null bs=1m" - see if that works.

Blockbridge : Ultra low latency all-NVME shared storage for Proxmox - https://www.blockbridge.com/proxmox
Thanks for the suggestion. Here is the output:

dd if=/dev/sdh of=/dev/null bs=1M
dd: error reading '/dev/sdh': Input/output error
89+1 records in
89+1 records out
93442048 bytes (93 MB, 89 MiB) copied, 1.8383 s, 50.8 MB/s

Yeah it shows I/O error. The disk is 95% used but it is really strange as the VM is starting and working correctly.
I will try to check the hardware but I think the backup of passed through disk has never worked for me.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!