h97m-plus weird iommu


New Member
Jun 22, 2023
I have an h97m-plus motherboard with an i7-4790. In the bios I've enabled intel vt-d, but in the proxmox webui it says iommu not detected. However when I boot and see the 1sec proxmox grub menu, I hit e and add "intel_iommu=on iommu=pt", and voila, iommu works, mostly. Both nics on my pci-e dual nic pass through as one unit, and I'm guessing that's expected for this device. Then I have 2x pci (legacy) nics, but I'm only able to get one of those to pass through, maybe because of shared pci bus?

Anyway, so I create /etc/default/grub.d/iommu.cfg with contents
GRUB_CMDLINE_LINUX="$GRUB_CMDLINE_LINUX intel_iommu=on iommu=pt"
I run "update-grub" and I see that in /boot/grub/grub.cfg that my iommu file was added. It comes in after the zfs linux grub command line entry since I'm using zfs if that's relevant.
I reboot and the computer hangs on the "press f2 or del for bios" screen. I turn off and on again and it boots, but no iommu. So I can only get iommu running if I manually add it in grub while htting 'e' when booting. Anything I'm missing?
Last edited:
Ah, looking at that manual page I am using systemd-boot, I just assumed it to be a themed version of GRUB. Do I then just edit /etc/kernel/cmdline then?

cat /proc/cmdline
initrd=\EFI\proxmox\6.2.16-3-pve\initrd.img-6.2.16-3-pve root=ZFS=rpool/ROOT/pve-1 boot=zfs intel_iommu=on iommu=pt

cat /etc/kernel/cmdline
root=ZFS=rpool/ROOT/pve-1 boot=zfs


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!